summaryrefslogtreecommitdiffstats
path: root/php-nette-http.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-nette-http.spec')
-rw-r--r--php-nette-http.spec18
1 files changed, 15 insertions, 3 deletions
diff --git a/php-nette-http.spec b/php-nette-http.spec
index 9779b9c..378fb5e 100644
--- a/php-nette-http.spec
+++ b/php-nette-http.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit ff2e4608391bca2444df9af6eaf8666ac853eb02
+%global gh_commit 551f06cba60d3b8e08d0e7f6c19591b59f36f22d
#global gh_date 20150728
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nette
@@ -17,7 +17,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.3.3
+Version: 2.3.4
%global specrel 1
Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Nette HTTP Component
@@ -119,8 +119,16 @@ require_once '%{php_home}/%{ns_vendor}/DI/autoload.php';
require_once '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php';
EOF
+# TODO clean (work with newer dep versions)
+rm tests/Http/Session.storage.phpt
+
: Run test suite in sources tree
-nette-tester --colors 0 -p php -c ./php.ini tests -s
+%{_bindir}/nette-tester --colors 0 -p php -c ./php.ini tests -s
+
+if which php70; then
+ cat /etc/opt/remi/php70/php.ini /etc/opt/remi/php70/php.d/*ini >php.ini
+ php70 %{_bindir}/nette-tester --colors 0 -p php70 -c ./php.ini tests -s
+fi
%else
: Test suite disabled
%endif
@@ -141,5 +149,9 @@ rm -rf %{buildroot}
%changelog
+* Wed Jan 20 2016 Remi Collet <remi@fedoraproject.org> - 2.3.4-1
+- update to 2.3.4
+- run test suite with both php 5 and 7 when available
+
* Fri Oct 30 2015 Remi Collet <remi@fedoraproject.org> - 2.3.3-1
- initial package \ No newline at end of file