summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-06 09:46:37 +0200
committerRemi Collet <remi@remirepo.net>2017-08-06 09:46:37 +0200
commit21207db9866f8695d0e8d4d45ac1888fee507d50 (patch)
treec247c71a639126fa26b26f31fa8a2125f30eef6f
parent332764c2d813f082c60c707ef047e6ef7f820b35 (diff)
v2.4.6
-rw-r--r--.gitignore7
-rw-r--r--php-nette-http.spec26
2 files changed, 17 insertions, 16 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/php-nette-http.spec b/php-nette-http.spec
index daa210c..f66a88c 100644
--- a/php-nette-http.spec
+++ b/php-nette-http.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit ef812049a89866eff5aa6b1a39f1a4d8c9adc607
+%global gh_commit 920984c48f59a91415dab9d231eb264cb42ec00e
#global gh_date 20150728
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nette
@@ -17,7 +17,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.4.5
+Version: 2.4.6
%global specrel 1
Release: %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Nette HTTP Component
@@ -120,21 +120,12 @@ require_once '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php';
EOF
: Run test suite in sources tree
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/nette-tester --colors 0 -p php56 -C tests -s
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/nette-tester --colors 0 -p php71 -C tests -s
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/nette-tester --colors 0 -p php -C tests -s
-# remirepo:2
-fi
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/nette-tester --colors 0 -p $cmd -C tests -s || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
@@ -156,6 +147,9 @@ rm -rf %{buildroot}
%changelog
+* Sat Aug 5 2017 Remi Collet <remi@remirepo.net> - 2.4.6-1
+- Update to 2.4.6
+
* Mon Mar 20 2017 Remi Collet <remi@remirepo.net> - 2.4.5-1
- Update to 2.4.5