summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-01 07:04:59 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-01 07:04:59 +0200
commit63072628aff45a14355fee70ebe44ccef6fa7735 (patch)
treec80ce74dd4462a7c3621f1d88a2dd492b4d5fa64
parent61748eea9ef2bd7bf5285f0312308f3510f81fdd (diff)
php-nette-forms: 2.3.9
-rw-r--r--composer.json35
-rw-r--r--php-nette-forms.spec15
2 files changed, 44 insertions, 6 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..41037fd
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,35 @@
+{
+ "name": "nette/forms",
+ "description": "Nette Forms: greatly facilitates web forms",
+ "homepage": "https://nette.org",
+ "license": ["BSD-3-Clause", "GPL-2.0", "GPL-3.0"],
+ "authors": [
+ {
+ "name": "David Grudl",
+ "homepage": "https://davidgrudl.com"
+ },
+ {
+ "name": "Nette Community",
+ "homepage": "https://nette.org/contributors"
+ }
+ ],
+ "require": {
+ "php": ">=5.3.1",
+ "nette/component-model": "~2.2.0",
+ "nette/http": "~2.2",
+ "nette/utils": "~2.2"
+ },
+ "require-dev": {
+ "nette/di": "~2.3",
+ "nette/tester": "~1.3",
+ "latte/latte": "~2.3.2",
+ "tracy/tracy": "~2.2"
+ },
+ "conflict": {
+ "nette/nette": "<2.2"
+ },
+ "autoload": {
+ "classmap": ["src/"]
+ },
+ "minimum-stability": "dev"
+}
diff --git a/php-nette-forms.spec b/php-nette-forms.spec
index 25a50d8..cef364e 100644
--- a/php-nette-forms.spec
+++ b/php-nette-forms.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 0cb5a8534bd446824ed6f63af3b4479c11361768
+%global gh_commit e32577062a2544fedac8a95fbc393ab98a3291c7
#global gh_date 20150728
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nette
@@ -17,7 +17,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.3.8
+Version: 2.3.9
%global specrel 1
Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Nette Forms: greatly facilitates web forms
@@ -52,12 +52,12 @@ BuildRequires: php-composer(tracy/tracy) >= 2.2
# from composer.json, "require": {
# "php": ">=5.3.1"
-# "nette/component-model": "~2.2",
+# "nette/component-model": "~2.2.0",
# "nette/http": "~2.2",
# "nette/utils": "~2.2"
Requires: php(language) >= 5.3.1
-Requires: php-composer(%{gh_owner}/component-model) >= 2.2
-Requires: php-composer(%{gh_owner}/component-model) < 3
+Requires: php-composer(%{gh_owner}/component-model) >= 2.2.0
+Requires: php-composer(%{gh_owner}/component-model) < 2.3
Requires: php-composer(%{gh_owner}/http) >= 2.2
Requires: php-composer(%{gh_owner}/http) < 3
Requires: php-composer(%{gh_owner}/utils) >= 2.2
@@ -155,6 +155,9 @@ rm -rf %{buildroot}
%changelog
+* Wed Jun 1 2016 Remi Collet <remi@fedoraproject.org> - 2.3.9-1
+- update to 2.3.9
+
* Sat Feb 20 2016 Remi Collet <remi@fedoraproject.org> - 2.3.8-1
- update to 2.3.8
@@ -163,4 +166,4 @@ rm -rf %{buildroot}
- run test suite with both php 5 and 7 when available
* Tue Oct 20 2015 Remi Collet <remi@fedoraproject.org> - 2.3.6-1
-- initial package \ No newline at end of file
+- initial package