summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-07-31 17:25:58 +0200
committerRemi Collet <fedora@famillecollet.com>2016-07-31 17:25:58 +0200
commitef2d760b2c0aca02c2de5350ceb3516c88c88fc6 (patch)
tree5a685d3e6f5ce16d79aebb3091c67a864bb06384
parent6c9165e5dc7b30f460b526893c86322ec17a7f4d (diff)
php-nette-di: 2.3.12
-rw-r--r--php-nette-di.spec27
1 files changed, 21 insertions, 6 deletions
diff --git a/php-nette-di.spec b/php-nette-di.spec
index abca2c5..c4668e7 100644
--- a/php-nette-di.spec
+++ b/php-nette-di.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 3f8347bbcac706e1ced651c7beb9affd66298473
+%global gh_commit aed06c37a722a1450854176f1d0b11de473092f1
#global gh_date 20150728
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nette
@@ -17,7 +17,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.3.11
+Version: 2.3.12
%global specrel 1
Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Nette Dependency Injection Component
@@ -120,12 +120,24 @@ require_once '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php';
EOF
: Run test suite in sources tree
+# remirepo:13
+ret=0
+run=0
+if which php56; then
+ cat /opt/remi/php56/root/etc/php.ini /opt/remi/php56/root/etc/php.d/*ini >php.ini
+ php56 %{_bindir}/nette-tester --colors 0 -p php -c ./php.ini tests -s || ret=1
+ run=1
+fi
+if which php71; then
+ cat /etc/opt/remi/php71/php.ini /etc/opt/remi/php70/php.d/*ini >php.ini
+ php71 %{_bindir}/nette-tester --colors 0 -p php -c ./php.ini tests -s || ret=1
+ run=1
+fi
+if [ $run -eq 0 ]; then
%{_bindir}/nette-tester --colors 0 -p php -c ./php.ini tests -s
-
-if which php70; then
- cat /etc/opt/remi/php70/php.ini /etc/opt/remi/php70/php.d/*ini >php.ini
- php70 %{_bindir}/nette-tester --colors 0 -p php70 -c ./php.ini tests -s
+# remirepo:2
fi
+exit $ret
%else
: Test suite disabled
%endif
@@ -146,6 +158,9 @@ rm -rf %{buildroot}
%changelog
+* Sun Jul 31 2016 Remi Collet <remi@fedoraproject.org> - 2.3.12-1
+- update to 2.3.12
+
* Mon Jun 20 2016 Remi Collet <remi@fedoraproject.org> - 2.3.11-1
- update to 2.3.11