summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-08-05 11:32:28 +0200
committerRemi Collet <fedora@famillecollet.com>2016-08-05 11:32:28 +0200
commit3a6ea9282aa2c96c84140882a9c7b24315b02ef2 (patch)
tree8133c97ca0780202de4af0e3935c47cd856b10b0
parent7cc65b73c1ccabfd20a77500950737b9caa305f0 (diff)
php-nette: cleanup test suite
-rw-r--r--php-nette-di-dev.spec12
1 files changed, 4 insertions, 8 deletions
diff --git a/php-nette-di-dev.spec b/php-nette-di-dev.spec
index 8637bf6..4835c4b 100644
--- a/php-nette-di-dev.spec
+++ b/php-nette-di-dev.spec
@@ -108,8 +108,6 @@ cp -pr src/* %{buildroot}%{php_home}/%{ns_vendor}/
%check
%if %{with_tests}
-: Generate configuration
-cat /etc/php.ini /etc/php.d/*ini >php.ini
export LANG=fr_FR.utf8
: See https://github.com/nette/di/commit/0b83ea7a788cef9d2bceafd543201aa309790ed3
@@ -124,21 +122,19 @@ require_once '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php';
EOF
: Run test suite in sources tree
-# remirepo:13
+# remirepo:11
ret=0
run=0
if which php56; then
- cat /opt/remi/php56/root/etc/php.ini /opt/remi/php56/root/etc/php.d/*ini >php.ini
- php56 %{_bindir}/nette-tester --colors 0 -p php56 -c ./php.ini tests -s || ret=1
+ php56 %{_bindir}/nette-tester --colors 0 -p php56 -C tests -s || ret=1
run=1
fi
if which php71; then
- cat /etc/opt/remi/php71/php.ini /etc/opt/remi/php71/php.d/*ini >php.ini
- php71 %{_bindir}/nette-tester --colors 0 -p php71 -c ./php.ini tests -s || ret=1
+ php71 %{_bindir}/nette-tester --colors 0 -p php71 -C tests -s || ret=1
run=1
fi
if [ $run -eq 0 ]; then
-%{_bindir}/nette-tester --colors 0 -p php -c ./php.ini tests -s
+%{_bindir}/nette-tester --colors 0 -p php -C tests -s
# remirepo:2
fi
exit $ret