summaryrefslogtreecommitdiffstats
path: root/php-nette-database-dev.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-nette-database-dev.spec')
-rw-r--r--php-nette-database-dev.spec16
1 files changed, 8 insertions, 8 deletions
diff --git a/php-nette-database-dev.spec b/php-nette-database-dev.spec
index 2c73826..a8d444c 100644
--- a/php-nette-database-dev.spec
+++ b/php-nette-database-dev.spec
@@ -34,6 +34,8 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
# pull a git snapshot to get test sutie
Source1: makesrc.sh
+Patch0: %{name}-upstream.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-composer(theseer/autoload)
@@ -97,6 +99,8 @@ To use this library, you just have to add, in your project:
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1
+
%build
: Generate a classmap autoloader
@@ -117,8 +121,6 @@ cp -pr src/* %{buildroot}%{php_home}/%{ns_vendor}/
%check
%if %{with_tests}
-: Generate configuration
-cat /etc/php.ini /etc/php.d/*ini >php.ini
export LANG=fr_FR.utf8
%if 0%{?rhel} != 5
@@ -140,21 +142,19 @@ require_once '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php';
EOF
: Run test suite in sources tree
-# remirepo:13
+# remirepo:11
ret=0
run=0
if which php56; then
- cat /opt/remi/php56/root/etc/php.ini /opt/remi/php56/root/etc/php.d/*ini >php.ini
- php56 %{_bindir}/nette-tester --colors 0 -p php56 -c ./php.ini tests -s || ret=1
+ php56 %{_bindir}/nette-tester --colors 0 -p php56 -C tests -s || ret=1
run=1
fi
if which php71; then
- cat /etc/opt/remi/php71/php.ini /etc/opt/remi/php71/php.d/*ini >php.ini
- php71 %{_bindir}/nette-tester --colors 0 -p php71 -c ./php.ini tests -s || ret=1
+ php71 %{_bindir}/nette-tester --colors 0 -p php71 -C tests -s || ret=1
run=1
fi
if [ $run -eq 0 ]; then
-%{_bindir}/nette-tester --colors 0 -p php -c ./php.ini tests -s
+%{_bindir}/nette-tester --colors 0 -p php -C tests -s
# remirepo:2
fi
exit $ret