summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-10-30 17:24:53 +0100
committerRemi Collet <fedora@famillecollet.com>2015-10-30 17:24:53 +0100
commit5cab6b5204923673946c0f1a04d2c56e5c1ce81d (patch)
treeddca330454515099a01928f129b779bef77cef62
php-nette-database: 2.3.7, new package
-rw-r--r--Makefile4
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-nette-database.spec157
3 files changed, 189 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..e9a1ec5
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer-$VERSION.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-nette-database.spec b/php-nette-database.spec
new file mode 100644
index 0000000..bac8ed2
--- /dev/null
+++ b/php-nette-database.spec
@@ -0,0 +1,157 @@
+# remirepo/fedora spec file for php-nette-database
+#
+# Copyright (c) 2015 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit 32ab8af7abb405c6415ef335d3395dea9d575859
+#global gh_date 20150728
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner nette
+%global gh_project database
+%global ns_vendor Nette
+%global ns_project Database
+%global php_home %{_datadir}/php
+%global with_tests 0%{!?_without_tests:1}
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 2.3.7
+%global specrel 1
+Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
+Summary: Nette Database Component
+
+Group: Development/Libraries
+License: BSD or GPLv2 or GPLv3
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: %{name}-%{version}-%{gh_short}.tgz
+# pull a git snapshot to get test sutie
+Source1: makesrc.sh
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php-composer(theseer/autoload)
+%if %{with_tests}
+BuildRequires: php(language) >= 5.3.1
+BuildRequires: php-pdo
+BuildRequires: php-composer(%{gh_owner}/caching) >= 2.2
+BuildRequires: php-composer(%{gh_owner}/utils) >= 2.2
+BuildRequires: php-date
+BuildRequires: php-json
+BuildRequires: php-pcre
+BuildRequires: php-spl
+# From composer.json, "require-dev": {
+# "nette/tester": "~1.3"
+# "nette/di": "~2.3",
+# "mockery/mockery": "~0.9.1"
+BuildRequires: php-composer(%{gh_owner}/tester) >= 1.3
+BuildRequires: php-composer(%{gh_owner}/di) >= 2.3
+BuildRequires: php-composer(mockery/mockery) >= 0.9.1
+%endif
+
+# from composer.json, "require": {
+# "php": ">=5.3.1"
+# "ext-pdo": "*",
+# "nette/caching": "~2.2",
+# "nette/utils": "^2.3.5"
+Requires: php(language) >= 5.3.1
+Requires: php-pdo
+Requires: php-composer(%{gh_owner}/caching) >= 2.2
+Requires: php-composer(%{gh_owner}/caching) < 3
+Requires: php-composer(%{gh_owner}/utils) >= 2.3.5
+Requires: php-composer(%{gh_owner}/utils) < 3
+# from phpcompatinfo report for version 2.3.7
+Requires: php-date
+Requires: php-json
+Requires: php-pcre
+Requires: php-spl
+
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+Nette provides a powerful layer for accessing your database easily.
+
+- composes SQL queries with ease
+- easily fetches data
+- uses efficient queries and does not transmit unnecessary data
+
+The Nette\Database\Connection class is a wrapper around the PDO
+and represents a connection to the database. The core functionality
+is provided by Nette\Database\Context. Nette\Database\Table layer
+provides an enhanced layer for table querying.
+
+To use this library, you just have to add, in your project:
+ require_once '%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php';
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+: Generate a classmap autoloader
+phpab --output src/%{ns_project}/autoload.php src
+
+cat << 'EOF' | tee -a src/%{ns_project}/autoload.php
+// Dependencies
+require_once '%{php_home}/%{ns_vendor}/Caching/autoload.php';
+require_once '%{php_home}/%{ns_vendor}/Utils/autoload.php';
+EOF
+
+
+%install
+rm -rf %{buildroot}
+mkdir -p %{buildroot}%{php_home}/%{ns_vendor}
+cp -pr src/* %{buildroot}%{php_home}/%{ns_vendor}/
+
+
+%check
+%if %{with_tests}
+: Generate configuration
+cat /etc/php.ini /etc/php.d/*ini >php.ini
+export LANG=fr_FR.utf8
+
+%if 0%{?rhel} != 5
+: Generate minimal Sqlite condiguration
+cat << 'EOF' | tee tests/Database/databases.ini
+[sqlite]
+dsn = "sqlite::memory:"
+EOF
+%endif
+
+: Generate autoloader
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{php_home}/Tester/autoload.php';
+require_once '%{php_home}/%{ns_vendor}/DI/autoload.php';
+require_once '%{php_home}/Mockery/autoload.php';
+require_once '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php';
+EOF
+
+: Run test suite in sources tree
+nette-tester --colors 0 -p php -c ./php.ini tests -s
+%else
+: Test suite disabled
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license license.md
+%doc readme.md contributing.md
+%doc composer.json
+%{php_home}/%{ns_vendor}/%{ns_project}
+%{php_home}/%{ns_vendor}/Bridges
+
+
+%changelog
+* Fri Oct 30 2015 Remi Collet <remi@fedoraproject.org> - 2.3.7-1
+- initial package \ No newline at end of file