summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-10-19 07:13:35 +0200
committerRemi Collet <fedora@famillecollet.com>2016-10-19 07:13:35 +0200
commit2db3bbbc7b6aa5785e6d501cfe8aaec4c2687ad2 (patch)
treec7834a20dd49d3108e4248693fe9d791ed495f9a
parentdfa7d69660e7a9c2179b92bf323e91b223c59d11 (diff)
php-nette-database: 2.4.1
-rw-r--r--php-nette-database-dev.spec11
-rw-r--r--php-nette-database-upstream.patch25
2 files changed, 5 insertions, 31 deletions
diff --git a/php-nette-database-dev.spec b/php-nette-database-dev.spec
index a8d444c..7f4f509 100644
--- a/php-nette-database-dev.spec
+++ b/php-nette-database-dev.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 05aa9112f3da7cf0ef799ad6b0fe223485deb827
+%global gh_commit 7a7b51520f3d98e3f6c38df5495ac775463972d5
#global gh_date 20150728
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nette
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.4.0
+Version: 2.4.1
%global specrel 1
Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Nette Database Component
@@ -34,8 +34,6 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
# pull a git snapshot to get test sutie
Source1: makesrc.sh
-Patch0: %{name}-upstream.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-composer(theseer/autoload)
@@ -99,8 +97,6 @@ To use this library, you just have to add, in your project:
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
-
%build
: Generate a classmap autoloader
@@ -178,6 +174,9 @@ rm -rf %{buildroot}
%changelog
+* Wed Oct 19 2016 Remi Collet <remi@fedoraproject.org> - 2.4.1-1
+- update to 2.4.1
+
* Thu Aug 4 2016 Remi Collet <remi@fedoraproject.org> - 2.4.0-1
- update to 2.4.0
- raise dependency on PHP >= 5.6
diff --git a/php-nette-database-upstream.patch b/php-nette-database-upstream.patch
deleted file mode 100644
index e11bcd1..0000000
--- a/php-nette-database-upstream.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 9e7a1dcd9dc482366a52cf328bdb441faf451dad Mon Sep 17 00:00:00 2001
-From: David Grudl <david@grudl.com>
-Date: Thu, 21 Jul 2016 13:40:08 +0200
-Subject: [PATCH] tests: fixed compatibility with PHP 7.1
-
-https://wiki.php.net/rfc/invalid_strings_in_arithmetic
----
- tests/Database/Table/Selection.page().phpt | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/tests/Database/Table/Selection.page().phpt b/tests/Database/Table/Selection.page().phpt
-index 2550625..96b13bd 100644
---- a/tests/Database/Table/Selection.page().phpt
-+++ b/tests/Database/Table/Selection.page().phpt
-@@ -60,8 +60,8 @@ test(function () use ($context) { //less items than $itemsPerPage
-
- // SQL Server throw PDOException 'The number of rows provided for a FETCH clause must be greater then zero.'
- if ($driverName !== 'sqlsrv') {
-- test(function () use ($context) { //invalid params
-+ Assert::error(function () use ($context) { //invalid params
- $tags = $context->table('tag')->page('foo', 'bar');
- Assert::equal(0, count($tags)); //no items
-- });
-+ }, PHP_VERSION_ID >= 70100 ? [[E_WARNING, 'A non-numeric value encountered']] : []);
- }