summaryrefslogtreecommitdiffstats
path: root/php-nette-component-model-dev.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-nette-component-model-dev.spec')
-rw-r--r--php-nette-component-model-dev.spec52
1 files changed, 39 insertions, 13 deletions
diff --git a/php-nette-component-model-dev.spec b/php-nette-component-model-dev.spec
index 62fe23f..654fac8 100644
--- a/php-nette-component-model-dev.spec
+++ b/php-nette-component-model-dev.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 07bce436051fd92d084642ce7a47f00045e0d1e5
+%global gh_commit 9b5817b246bf409b8f0f8309c23e599dd8729d28
#global gh_date 20150728
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nette
@@ -17,8 +17,8 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.2.4
-%global specrel 2
+Version: 2.3.0
+%global specrel 1
Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Nette Component Model
@@ -33,21 +33,25 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-composer(theseer/autoload)
%if %{with_tests}
-BuildRequires: php(language) >= 5.3.1
+BuildRequires: php(language) >= 5.6
BuildRequires: php-pcre
BuildRequires: php-reflection
-BuildRequires: php-composer(%{gh_owner}/utils) >= 2.3.5
+BuildRequires: php-composer(%{gh_owner}/utils) >= 2.4
# From composer.json, "require-dev": {
-# "nette/tester": "~1.4"
-BuildRequires: php-composer(%{gh_owner}/tester) >= 1.4
+# "nette/tester": "~2.0",
+# "tracy/tracy": "^2.3"
+# ignore tracy (pass without)
+BuildRequires: php-composer(%{gh_owner}/tester) >= 2.0
%endif
# from composer.json, "require": {
-# "php": ">=5.3.1"
-# "nette/utils": "^2.3.5"
-Requires: php(language) >= 5.3.1
-Requires: php-composer(%{gh_owner}/utils) >= 2.3.5
+# "php": ">=5.6.0",
+# "nette/utils": "^2.4"
+Requires: php(language) >= 5.6
+Requires: php-composer(%{gh_owner}/utils) >= 2.4
Requires: php-composer(%{gh_owner}/utils) < 3
+# from composer.json, "conflict": {
+Conflicts: php-composer(%{gh_owner}/application) < 2.4
# from phpcompatinfo report for version 2.2.4
Requires: php-pcre
Requires: php-spl
@@ -105,7 +109,24 @@ require_once '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php';
EOF
: Run test suite in sources tree
-nette-tester --colors 0 -p php -c ./php.ini tests -s
+# remirepo:13
+ret=0
+run=0
+if which php56; then
+ cat /opt/remi/php56/root/etc/php.ini /opt/remi/php56/root/etc/php.d/*ini >php.ini
+ php56 %{_bindir}/nette-tester --colors 0 -p php56 -c ./php.ini tests -s || ret=1
+ run=1
+fi
+if which php71; then
+ cat /etc/opt/remi/php71/php.ini /etc/opt/remi/php71/php.d/*ini >php.ini
+ php71 %{_bindir}/nette-tester --colors 0 -p php71 -c ./php.ini tests -s || ret=1
+ run=1
+fi
+if [ $run -eq 0 ]; then
+%{_bindir}/nette-tester --colors 0 -p php -c ./php.ini tests -s
+# remirepo:2
+fi
+exit $ret
%else
: Test suite disabled
%endif
@@ -125,8 +146,13 @@ rm -rf %{buildroot}
%changelog
+* Tue Aug 2 2016 Remi Collet <remi@fedoraproject.org> - 2.3.0-1
+- update to 2.3.0
+- raise dependency on PHP >= 5.6
+- raise dependency on nette/utils >= 2.4
+
* Tue Nov 3 2015 Remi Collet <remi@fedoraproject.org> - 2.2.4-2
- fix package description and summary
* Tue Oct 20 2015 Remi Collet <remi@fedoraproject.org> - 2.2.4-1
-- initial package \ No newline at end of file
+- initial package