summaryrefslogtreecommitdiffstats
path: root/php-nette-caching.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-06 10:23:29 +0200
committerRemi Collet <remi@remirepo.net>2017-08-06 10:23:29 +0200
commit82defe08a2e88b3b1289471dce78add2979861f0 (patch)
treee48dbbd70581035ac30075e08c9e4c331b46b892 /php-nette-caching.spec
parenta930aa89778ce3045765d0e24799adb3facc1c61 (diff)
switch
Diffstat (limited to 'php-nette-caching.spec')
-rw-r--r--php-nette-caching.spec71
1 files changed, 44 insertions, 27 deletions
diff --git a/php-nette-caching.spec b/php-nette-caching.spec
index 72a9d45..1609cde 100644
--- a/php-nette-caching.spec
+++ b/php-nette-caching.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 0cb5c2c91e92a155ca5c1700479476b80c30dece
+%global gh_commit 2436e530484a346d0a246733519ceaa40b943bd6
#global gh_date 20150728
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nette
@@ -17,7 +17,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.3.5
+Version: 2.5.3
%global specrel 1
Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Nette Caching Component
@@ -33,36 +33,39 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-composer(theseer/autoload)
%if %{with_tests}
-BuildRequires: php(language) >= 5.3.1
+BuildRequires: php(language) >= 5.6
BuildRequires: php-pdo
BuildRequires: php-date
BuildRequires: php-reflection
BuildRequires: php-composer(%{gh_owner}/finder) >= 2.2
-BuildRequires: php-composer(%{gh_owner}/utils) >= 2.2
+BuildRequires: php-composer(%{gh_owner}/utils) >= 2.4
# From composer.json, "require-dev": {
-# "nette/tester": "~1.6"
-# "nette/di": "~2.3",
-# "latte/latte": "~2.3.0"
-BuildRequires: php-composer(%{gh_owner}/tester) >= 1.6
-BuildRequires: php-composer(%{gh_owner}/di) >= 2.3
-BuildRequires: php-composer(latte/latte) >= 2.3
+# "nette/tester": "~2.0",
+# "nette/di": "^2.4 || ~3.0.0",
+# "latte/latte": "^2.4",
+# "tracy/tracy": "^2.4"
+BuildRequires: php-composer(%{gh_owner}/tester) >= 2.0
+BuildRequires: php-composer(%{gh_owner}/di) >= 2.4
+BuildRequires: php-composer(latte/latte) >= 2.4
+BuildRequires: php-composer(tracy/tracy) >= 2.4
%endif
# from composer.json, "require": {
-# "php": ">=5.3.1"
-# "nette/finder": "~2.2",
-# "nette/utils": "~2.2"
-Requires: php(language) >= 5.3.1
+# "php": ">=5.6.0",
+# "nette/finder": "^2.2 || ~3.0.0",
+# "nette/utils": "^2.4 || ~3.0.0"
+Requires: php(language) >= 5.6
Requires: php-composer(%{gh_owner}/finder) >= 2.2
-Requires: php-composer(%{gh_owner}/finder) < 3
-Requires: php-composer(%{gh_owner}/utils) >= 2.2
-Requires: php-composer(%{gh_owner}/utils) < 3
+Requires: php-composer(%{gh_owner}/finder) < 4
+Requires: php-composer(%{gh_owner}/utils) >= 2.4
+Requires: php-composer(%{gh_owner}/utils) < 4
# from phpcompatinfo report for version 2.3.3
Requires: php-pdo
+Requires: php-reflection
Requires: php-date
-Requires: php-spl
%if 0%{?fedora} > 21
Suggests: php-pecl(memcache)
+Suggests: php-pecl(memcached)
%endif
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
@@ -101,9 +104,11 @@ cp -pr src/* %{buildroot}%{php_home}/%{ns_vendor}/
%if %{with_tests}
: Ignore tests which require memcache
rm tests/Storages/*Memcache*
+# remirepo:3
+%if 0%{?rhel} == 5
+rm tests/Storages/SQLiteStorage.sliding.phpt
+%endif
-: Generate configuration
-cat /etc/php.ini /etc/php.d/*ini >php.ini
export LANG=fr_FR.utf8
: Generate autoloader
@@ -117,12 +122,13 @@ require_once '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php';
EOF
: Run test suite in sources tree
-%{_bindir}/nette-tester --colors 0 -p php -c ./php.ini tests -s
-
-if which php70; then
- cat /etc/opt/remi/php70/php.ini /etc/opt/remi/php70/php.d/*ini >php.ini
- php70 %{_bindir}/nette-tester --colors 0 -p php70 -c ./php.ini tests -s
-fi
+ret=0
+for cmd in php56 php71 php70 php; do
+ if which $cmd; then
+ $cmd %{_bindir}/nette-tester --colors 0 -p $cmd -C tests -s || ret=1
+ fi
+done
+exit $ret
%else
: Test suite disabled
%endif
@@ -143,6 +149,17 @@ rm -rf %{buildroot}
%changelog
+* Thu Feb 2 2017 Remi Collet <remi@fedoraproject.org> - 2.5.3-1
+- update to 2.5.3
+
+* Wed Oct 19 2016 Remi Collet <remi@fedoraproject.org> - 2.5.2-1
+- update to 2.5.2
+
+* Tue Aug 2 2016 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
+- update to 2.5.1
+- raise dependency on PHP >= 5.6
+- raise dependency on nette/utils >= 2.4
+
* Mon Feb 22 2016 Remi Collet <remi@fedoraproject.org> - 2.3.5-1
- update to 2.3.5
- run test suite with both PHP 7 and 7 when available
@@ -151,4 +168,4 @@ rm -rf %{buildroot}
- update to 2.3.4
* Tue Oct 20 2015 Remi Collet <remi@fedoraproject.org> - 2.3.3-1
-- initial package \ No newline at end of file
+- initial package