summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-20 13:20:55 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-20 13:20:55 +0200
commit87d41ec4aefad82c2be6a4e900ac1e4b446b0231 (patch)
treeeb554bededbf6a0e187b154193b7ab1669e20137
parent4ecd0c4d4f587d56aeccc2ef051f186e27f90317 (diff)
php-nette-bootstrap: 2.3.5
-rw-r--r--composer.json46
-rw-r--r--php-nette-bootstrap.spec19
2 files changed, 60 insertions, 5 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..1018199
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,46 @@
+{
+ "name": "nette/bootstrap",
+ "description": "Nette Bootstrap",
+ "homepage": "https://nette.org",
+ "license": ["BSD-3-Clause", "GPL-2.0", "GPL-3.0"],
+ "authors": [
+ {
+ "name": "David Grudl",
+ "homepage": "https://davidgrudl.com"
+ },
+ {
+ "name": "Nette Community",
+ "homepage": "https://nette.org/contributors"
+ }
+ ],
+ "require": {
+ "php": ">=5.3.1",
+ "nette/di": "~2.3.0",
+ "nette/utils": "~2.2"
+ },
+ "suggest": {
+ "nette/robot-loader": "to use Configurator::createRobotLoader()",
+ "tracy/tracy": "to use Configurator::enableDebugger()"
+ },
+ "require-dev": {
+ "nette/application": "~2.3",
+ "nette/caching": "~2.3",
+ "nette/database": "~2.3",
+ "nette/forms": "~2.3",
+ "nette/http": "~2.3",
+ "nette/mail": "~2.3",
+ "nette/robot-loader": "~2.2",
+ "nette/safe-stream": "~2.2",
+ "nette/security": "~2.3",
+ "nette/tester": "~1.3",
+ "latte/latte": "~2.2",
+ "tracy/tracy": "~2.3"
+ },
+ "conflict": {
+ "nette/nette": "<2.2"
+ },
+ "autoload": {
+ "classmap": ["src/"]
+ },
+ "minimum-stability": "dev"
+}
diff --git a/php-nette-bootstrap.spec b/php-nette-bootstrap.spec
index 3743f6c..cbea178 100644
--- a/php-nette-bootstrap.spec
+++ b/php-nette-bootstrap.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit e32964df66f2c5a3a50b229204f583d20c1f6829
+%global gh_commit 1fc6e52b790864d2973d479a4460a89cec1f51f8
#global gh_date 20150728
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nette
@@ -17,7 +17,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.3.4
+Version: 2.3.5
%global specrel 1
Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Nette Bootstrap
@@ -70,12 +70,12 @@ BuildRequires: php-composer(%{gh_owner}/tester) >= 1.3
# from composer.json, "require": {
# "php": ">=5.3.1"
-# "nette/di": "~2.3",
+# "nette/di": "~2.3.0",
# "nette/utils": "~2.2"
Requires: php(language) >= 5.3.1
Requires: php-tokenizer
Requires: php-composer(%{gh_owner}/di) >= 2.3
-Requires: php-composer(%{gh_owner}/di) < 3
+Requires: php-composer(%{gh_owner}/di) < 2.4
Requires: php-composer(%{gh_owner}/utils) >= 2.2
Requires: php-composer(%{gh_owner}/utils) < 3
# from phpcompatinfo report for version 2.3.3
@@ -146,6 +146,12 @@ EOF
: Run test suite in sources tree
nette-tester --colors 0 -p php -c ./php.ini tests -s
+
+# remirepo:4
+if which php70; then
+ cat /etc/opt/remi/php70/php.ini /etc/opt/remi/php70/php.d/*ini >php.ini
+ php70 %{_bindir}/nette-tester --colors 0 -p php70 -c ./php.ini tests -s
+fi
%else
: Test suite disabled
%endif
@@ -166,6 +172,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Jun 20 2016 Remi Collet <remi@fedoraproject.org> - 2.3.5-1
+- update to 2.3.5
+
* Mon Nov 30 2015 Remi Collet <remi@fedoraproject.org> - 2.3.4-1
- update to 2.3.4
@@ -173,4 +182,4 @@ rm -rf %{buildroot}
- more tests
* Tue Oct 20 2015 Remi Collet <remi@fedoraproject.org> - 2.3.3-1
-- initial package \ No newline at end of file
+- initial package