summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-06-02 09:33:21 +0200
committerRemi Collet <remi@remirepo.net>2017-06-02 09:33:21 +0200
commit852b22293963f6fdc2352d416f74b40d361bae31 (patch)
treeff8965f46ef341446976a00ff13dadc255a2b8f9
parentc37afd9dd1251ee767d71bad94d2c2eceea4d5c2 (diff)
cleanupv2.3
-rw-r--r--composer-dev.json53
-rw-r--r--php-nette-application-dev.spec238
-rw-r--r--php-nette-application-upstream.patch173
3 files changed, 0 insertions, 464 deletions
diff --git a/composer-dev.json b/composer-dev.json
deleted file mode 100644
index 3e99552..0000000
--- a/composer-dev.json
+++ /dev/null
@@ -1,53 +0,0 @@
-{
- "name": "nette/application",
- "description": "Nette Application MVC Component",
- "homepage": "https://nette.org",
- "license": ["BSD-3-Clause", "GPL-2.0", "GPL-3.0"],
- "authors": [
- {
- "name": "David Grudl",
- "homepage": "https://davidgrudl.com"
- },
- {
- "name": "Nette Community",
- "homepage": "https://nette.org/contributors"
- }
- ],
- "require": {
- "php": ">=5.6.0",
- "nette/component-model": "^2.3",
- "nette/http": "^2.2",
- "nette/reflection": "^2.2",
- "nette/utils": "^2.4 || ~3.0.0"
- },
- "suggest": {
- "nette/forms": "Allows to use Nette\\Application\\UI\\Form",
- "latte/latte": "Allows using Latte in templates"
- },
- "require-dev": {
- "nette/tester": "^2.0",
- "nette/di": "^2.4 || ~3.0.0",
- "nette/forms": "^2.4",
- "nette/robot-loader": "^2.4.2 || ^3.0",
- "nette/security": "^2.4",
- "latte/latte": "^2.4.3",
- "tracy/tracy": "^2.4",
- "mockery/mockery": "^0.9.5"
- },
- "conflict": {
- "nette/nette": "<2.2",
- "nette/di": "<2.4",
- "nette/forms": "<2.4",
- "nette/latte": "<2.4"
- },
- "autoload": {
- "classmap": ["src/"],
- "files": ["src/compatibility.php"]
- },
- "minimum-stability": "dev",
- "extra": {
- "branch-alias": {
- "dev-master": "2.4-dev"
- }
- }
-}
diff --git a/php-nette-application-dev.spec b/php-nette-application-dev.spec
deleted file mode 100644
index ba4fa97..0000000
--- a/php-nette-application-dev.spec
+++ /dev/null
@@ -1,238 +0,0 @@
-# remirepo/fedora spec file for php-nette-application
-#
-# Copyright (c) 2015-2017 Remi Collet
-# License: CC-BY-SA
-# http://creativecommons.org/licenses/by-sa/4.0/
-#
-# Please, preserve the changelog entries
-#
-%global gh_commit cec392dd66d5432d47b856d70ac64a5ce15f2538
-#global gh_date 20150728
-%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner nette
-%global gh_project application
-%global ns_vendor Nette
-%global ns_project Application
-%global php_home %{_datadir}/php
-%global with_tests 0%{!?_without_tests:1}
-
-Name: php-%{gh_owner}-%{gh_project}
-Version: 2.4.5
-%global specrel 1
-Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
-Summary: Nette Application MVC Component
-
-Group: Development/Libraries
-License: BSD or GPLv2 or GPLv3
-URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: %{name}-%{version}-%{gh_short}.tgz
-# pull a git snapshot to get test sutie
-Source1: makesrc.sh
-
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildArch: noarch
-BuildRequires: php-composer(theseer/autoload)
-%if %{with_tests}
-BuildRequires: php(language) >= 5.6
-BuildRequires: php-composer(%{gh_owner}/component-model) >= 2.3
-BuildRequires: php-composer(%{gh_owner}/http) >= 2.2
-BuildRequires: php-composer(%{gh_owner}/reflection) >= 2.2
-BuildRequires: php-composer(%{gh_owner}/utils) >= 2.4
-BuildRequires: php-pcre
-BuildRequires: php-reflection
-BuildRequires: php-spl
-# From composer.json, "require-dev": {
-# "nette/tester": "^2.0",
-# "nette/di": "^2.4 || ~3.0.0",
-# "nette/forms": "^2.4",
-# "nette/robot-loader": "~2.4.2 || ^3.0",
-# "nette/security": "^2.4",
-# "latte/latte": "^2.4.3",
-# "tracy/tracy": "^2.4",
-# "mockery/mockery": "^0.9.5"
-BuildRequires: php-composer(%{gh_owner}/tester) >= 2.0
-BuildRequires: php-composer(%{gh_owner}/di) >= 2.4
-BuildRequires: php-composer(%{gh_owner}/forms) >= 2.4
-BuildRequires: php-composer(%{gh_owner}/robot-loader) >= 2.4.2
-BuildRequires: php-composer(%{gh_owner}/security) >= 2.4
-BuildRequires: php-composer(latte/latte) >= 2.4.3
-BuildRequires: php-composer(tracy/tracy) >= 2.4
-BuildRequires: php-composer(mockery/mockery) >= 0.9.5
-%endif
-
-# from composer.json, "require": {
-# "php": ">=5.6.0"
-# "nette/component-model": "^2.3",
-# "nette/http": "^2.2",
-# "nette/reflection": "^2.2",
-# "nette/utils": "^2.4 || ~3.0.0"
-Requires: php(language) >= 5.6
-Requires: php-composer(%{gh_owner}/component-model) >= 2.3
-Requires: php-composer(%{gh_owner}/component-model) < 3
-Requires: php-composer(%{gh_owner}/http) >= 2.2
-Requires: php-composer(%{gh_owner}/http) < 3
-Requires: php-composer(%{gh_owner}/reflection) >= 2.2
-Requires: php-composer(%{gh_owner}/reflection) < 3
-Requires: php-composer(%{gh_owner}/utils) >= 2.4
-Requires: php-composer(%{gh_owner}/utils) < 4
-# from composer.json, "suggest": {
-# "nette/forms": "Allows to use Nette\\Application\\UI\\Form",
-# "latte/latte": "Allows using Latte in templates"
-%if 0%{?fedora} > 21
-Suggests: php-composer(%{gh_owner}/forms)
-Suggests: php-composer(latte/latte)
-%endif
-# from phpcompatinfo report for version 2.4.0
-Requires: php-pcre
-Requires: php-reflection
-Requires: php-spl
-
-Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
-
-
-%description
-Model-View-Controller is a software architecture that was created to
-satisfy the need to separate utility code (controller) from application
-logic code (model) and from code for displaying data (view) in applications
-with graphical user interface. With this approach we make the application
-better understandable, simplify future development and enable testing each
-unit of the application separately.
-
-To use this library, you just have to add, in your project:
- require_once '%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php';
-
-
-%prep
-%setup -q -n %{gh_project}-%{gh_commit}
-
-mv src/compatibility.php src/%{ns_project}/
-
-
-%build
-: Generate a classmap autoloader
-phpab --output src/%{ns_project}/autoload.php src
-
-cat << 'EOF' | tee -a src/%{ns_project}/autoload.php
-// Dependencies
-foreach (array(
- '%{php_home}/%{ns_vendor}/ComponentModel/autoload.php' => true,
- '%{php_home}/%{ns_vendor}/Http/autoload.php' => true,
- '%{php_home}/%{ns_vendor}/Reflection/autoload.php' => true,
- '%{php_home}/%{ns_vendor}/Utils/autoload.php' => true,
- // Optional
- '%{php_home}/%{ns_vendor}/Forms/autoload.php' => false,
- '%{php_home}/Latte/autoload.php' => false,
- ) as $dep => $mandatory) {
- if ($mandatory || file_exists($dep)) require_once($dep);
-}
-
-require_once __DIR__ . '/compatibility.php';
-EOF
-
-
-%install
-rm -rf %{buildroot}
-mkdir -p %{buildroot}%{php_home}/%{ns_vendor}
-cp -pr src/* %{buildroot}%{php_home}/%{ns_vendor}/
-
-
-%check
-%if %{with_tests}
-: Ignore failed test - under investigation
-rm tests/Bridges.DI/ApplicationExtension.scan.phpt
-%if 0%{?rhel} == 6
-rm tests/Application/MicroPresenter.response.phpt
-%endif
-
-export LANG=fr_FR.utf8
-
-: Generate autoloader
-mkdir vendor
-cat << 'EOF' | tee vendor/autoload.php
-<?php
-require_once '%{php_home}/Tester/autoload.php';
-require_once '%{php_home}/%{ns_vendor}/DI/autoload.php';
-require_once '%{php_home}/%{ns_vendor}/RobotLoader/autoload.php';
-require_once '%{php_home}/%{ns_vendor}/Security/autoload.php';
-require_once '%{php_home}/Mockery/autoload.php';
-require_once '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php';
-EOF
-
-: Run test suite in sources tree
-ret=0
-for cmd in php56 php70 php71 php; do
- if which $cmd; then
- $cmd %{_bindir}/nette-tester --colors 0 -p $cmd -C tests -s || ret=1
- fi
-done
-exit $ret
-%else
-: Test suite disabled
-%endif
-
-
-%clean
-rm -rf %{buildroot}
-
-
-%files
-%defattr(-,root,root,-)
-%{!?_licensedir:%global license %%doc}
-%license license.md
-%doc readme.md contributing.md
-%doc composer.json
-%{php_home}/%{ns_vendor}/%{ns_project}
-%{php_home}/%{ns_vendor}/Bridges
-
-
-%changelog
-* Thu Feb 2 2017 Remi Collet <remi@fedoraproject.org> - 2.4.5-1
-- update to 2.4.5
-
-* Thu Jan 19 2017 Remi Collet <remi@fedoraproject.org> - 2.4.4-1
-- update to 2.4.4
-
-* Wed Dec 21 2016 Remi Collet <remi@fedoraproject.org> - 2.4.3-1
-- update to 2.4.3
-
-* Tue Sep 27 2016 Remi Collet <remi@fedoraproject.org> - 2.4.2-1
-- update to 2.4.2
-
-* Thu Aug 4 2016 Remi Collet <remi@fedoraproject.org> - 2.4.1-2
-- fix autoloader
-
-* Thu Aug 4 2016 Remi Collet <remi@fedoraproject.org> - 2.4.1-1
-- update to 2.4.1
-- raise dependency on PHP >= 5.6
-- raise dependency on nette/utils >= 2.4
-- raise dependency on nette/component-model >= 2.3
-- drop dependency on nette/security
-
-* Mon Jun 20 2016 Remi Collet <remi@fedoraproject.org> - 2.3.13-1
-- update to 2.3.12
-
-* Mon May 30 2016 Remi Collet <remi@fedoraproject.org> - 2.3.12-3
-- add upstream patch for tests, fix FTBFS, thanks Koschei
-
-* Thu Apr 14 2016 Remi Collet <remi@fedoraproject.org> - 2.3.12-2
-- don't use include_once in autoloader
-
-* Wed Apr 6 2016 Remi Collet <remi@fedoraproject.org> - 2.3.12-1
-- update to 2.3.12
-
-* Sat Feb 20 2016 Remi Collet <remi@fedoraproject.org> - 2.3.11-1
-- update to 2.3.11
-
-* Fri Feb 12 2016 Remi Collet <remi@fedoraproject.org> - 2.3.10-1
-- update to 2.3.10
-
-* Wed Jan 20 2016 Remi Collet <remi@fedoraproject.org> - 2.3.9-1
-- update to 2.3.9
-- raise dependency on latte ~2.3.9
-
-* Thu Dec 3 2015 Remi Collet <remi@fedoraproject.org> - 2.3.8-1
-- update to 2.3.8
-- run test suite with both php 5 and 7 when available
-
-* Fri Oct 30 2015 Remi Collet <remi@fedoraproject.org> - 2.3.7-1
-- initial package
diff --git a/php-nette-application-upstream.patch b/php-nette-application-upstream.patch
deleted file mode 100644
index a46d10b..0000000
--- a/php-nette-application-upstream.patch
+++ /dev/null
@@ -1,173 +0,0 @@
-From e071611a93ce117c0983ad824c817c0ba0d242bb Mon Sep 17 00:00:00 2001
-From: David Grudl <david@grudl.com>
-Date: Tue, 17 May 2016 18:00:56 +0200
-Subject: [PATCH] tests: compatibility with DI & Latte 2.4
-
----
- tests/Bridges.DI/ApplicationExtension.basic.phpt | 2 +-
- tests/Bridges.DI/ApplicationExtension.invalidLink.phpt | 8 ++++----
- tests/Bridges.DI/ApplicationExtension.scan.phpt | 6 +++---
- tests/Bridges.DI/LatteExtension.basic.phpt | 2 +-
- tests/Bridges.DI/RoutingExtension.basic.phpt | 2 +-
- tests/Bridges.DI/RoutingExtension.cache.phpt | 6 +++---
- tests/Bridges.Latte/UIMacros.link.2.phpt | 4 ++--
- 7 files changed, 15 insertions(+), 15 deletions(-)
-
-diff --git a/tests/Bridges.DI/ApplicationExtension.basic.phpt b/tests/Bridges.DI/ApplicationExtension.basic.phpt
-index ee98341..d3b74cd 100644
---- a/tests/Bridges.DI/ApplicationExtension.basic.phpt
-+++ b/tests/Bridges.DI/ApplicationExtension.basic.phpt
-@@ -21,7 +21,7 @@ test(function () {
- $builder->addDefinition('myHttpRequest')->setFactory('Nette\Http\Request', array(new DI\Statement('Nette\Http\UrlScript')));
- $builder->addDefinition('myHttpResponse')->setClass('Nette\Http\Response');
-
-- $code = $compiler->compile(array(), 'Container1');
-+ $code = @$compiler->compile(array(), 'Container1'); // @ compatibility with 2.4
- eval($code);
-
- $container = new Container1;
-diff --git a/tests/Bridges.DI/ApplicationExtension.invalidLink.phpt b/tests/Bridges.DI/ApplicationExtension.invalidLink.phpt
-index 95d2fa4..fb11893 100644
---- a/tests/Bridges.DI/ApplicationExtension.invalidLink.phpt
-+++ b/tests/Bridges.DI/ApplicationExtension.invalidLink.phpt
-@@ -36,7 +36,7 @@ test(function () {
- presenter: Presenter1
- ');
- $compiler->addExtension('application', new ApplicationExtension(TRUE));
-- $code = $compiler->compile(NULL, 'Container4');
-+ $code = @$compiler->compile(NULL, 'Container4'); // @ compatibility with 2.4
- eval($code);
-
- $container = new Container4;
-@@ -57,7 +57,7 @@ test(function () {
- presenter: Presenter1
- ');
- $compiler->addExtension('application', new ApplicationExtension(TRUE));
-- $code = $compiler->compile(NULL, 'Container5');
-+ $code = @$compiler->compile(NULL, 'Container5'); // @ compatibility with 2.4
- eval($code);
-
- $container = new Container5;
-@@ -78,7 +78,7 @@ test(function () {
- presenter: Presenter1
- ');
- $compiler->addExtension('application', new ApplicationExtension(FALSE));
-- $code = $compiler->compile(NULL, 'Container6');
-+ $code = @$compiler->compile(NULL, 'Container6'); // @ compatibility with 2.4
- eval($code);
-
- $container = new Container6;
-@@ -99,7 +99,7 @@ test(function () {
- presenter: Presenter1
- ');
- $compiler->addExtension('application', new ApplicationExtension(FALSE));
-- $code = $compiler->compile(NULL, 'Container7');
-+ $code = @$compiler->compile(NULL, 'Container7'); // @ compatibility with 2.4
- eval($code);
-
- $container = new Container7;
-diff --git a/tests/Bridges.DI/ApplicationExtension.scan.phpt b/tests/Bridges.DI/ApplicationExtension.scan.phpt
-index 7535091..24e2e39 100644
---- a/tests/Bridges.DI/ApplicationExtension.scan.phpt
-+++ b/tests/Bridges.DI/ApplicationExtension.scan.phpt
-@@ -21,7 +21,7 @@ test(function () {
- $builder->addDefinition('myRouter')->setClass('Nette\Application\Routers\SimpleRouter');
- $builder->addDefinition('myHttpRequest')->setFactory('Nette\Http\Request', array(new DI\Statement('Nette\Http\UrlScript')));
- $builder->addDefinition('myHttpResponse')->setClass('Nette\Http\Response');
-- $code = $compiler->compile(array(
-+ $code = @$compiler->compile(array( // @ compatibility with 2.4
- 'application' => array('debugger' => FALSE),
- ), 'Container1');
- eval($code);
-@@ -42,7 +42,7 @@ test(function () {
- $builder->addDefinition('myRouter')->setClass('Nette\Application\Routers\SimpleRouter');
- $builder->addDefinition('myHttpRequest')->setFactory('Nette\Http\Request', array(new DI\Statement('Nette\Http\UrlScript')));
- $builder->addDefinition('myHttpResponse')->setClass('Nette\Http\Response');
-- $code = $compiler->compile(array(
-+ $code = @$compiler->compile(array( // @ compatibility with 2.4
- 'application' => array(
- 'scanDirs' => array(__DIR__ . '/files'),
- 'debugger' => FALSE,
-@@ -77,7 +77,7 @@ test(function () {
- setup:
- - setView(test)
- ', 'neon'));
-- $code = $compiler->compile($config, 'Container3');
-+ $code = @$compiler->compile($config, 'Container3'); // @ compatibility with 2.4
- eval($code);
-
- $container = new Container3;
-diff --git a/tests/Bridges.DI/LatteExtension.basic.phpt b/tests/Bridges.DI/LatteExtension.basic.phpt
-index 5f0d215..fc473f3 100644
---- a/tests/Bridges.DI/LatteExtension.basic.phpt
-+++ b/tests/Bridges.DI/LatteExtension.basic.phpt
-@@ -74,7 +74,7 @@ latte:
- $compiler = new DI\Compiler;
- $compiler->addExtension('latte', new Nette\Bridges\ApplicationDI\LatteExtension(NULL, FALSE));
- $compiler->addExtension('another', new AnotherExtension);
--$code = $compiler->compile($config, 'Container');
-+$code = @$compiler->compile($config, 'Container'); // @ compatibility with 2.4
- eval($code);
-
- $container = new Container;
-diff --git a/tests/Bridges.DI/RoutingExtension.basic.phpt b/tests/Bridges.DI/RoutingExtension.basic.phpt
-index b8d8f90..c05d116 100644
---- a/tests/Bridges.DI/RoutingExtension.basic.phpt
-+++ b/tests/Bridges.DI/RoutingExtension.basic.phpt
-@@ -23,7 +23,7 @@ test(function () {
-
- $compiler = new DI\Compiler;
- $compiler->addExtension('routing', new RoutingExtension(FALSE));
-- $code = $compiler->compile($config, 'Container1');
-+ $code = @$compiler->compile($config, 'Container1'); // @ compatibility with 2.4
- eval($code);
-
- $container = new Container1;
-diff --git a/tests/Bridges.DI/RoutingExtension.cache.phpt b/tests/Bridges.DI/RoutingExtension.cache.phpt
-index 9f1aad7..fd0d96d 100644
---- a/tests/Bridges.DI/RoutingExtension.cache.phpt
-+++ b/tests/Bridges.DI/RoutingExtension.cache.phpt
-@@ -39,7 +39,7 @@ test(function () {
-
- $compiler = new DI\Compiler;
- $compiler->addExtension('routing', new RoutingExtension(FALSE));
-- $code = $compiler->compile($config, 'Container1');
-+ $code = @$compiler->compile($config, 'Container1'); // @ compatibility with 2.4
- eval($code);
-
- $container = new Container1;
-@@ -60,7 +60,7 @@ test(function () {
-
- $compiler = new DI\Compiler;
- $compiler->addExtension('routing', new RoutingExtension(FALSE));
-- $code = $compiler->compile($config, 'Container2');
-+ $code = @$compiler->compile($config, 'Container2'); // @ compatibility with 2.4
- eval($code);
-
- $container = new Container2;
-@@ -88,5 +88,5 @@ Assert::exception(function () {
-
- $compiler = new DI\Compiler;
- $compiler->addExtension('routing', new RoutingExtension(FALSE));
-- $compiler->compile($config, 'Container3');
-+ @$compiler->compile($config, 'Container3'); // @ compatibility with 2.4
- }, 'Nette\DI\ServiceCreationException', 'Unable to cache router due to error: %a%');
-diff --git a/tests/Bridges.Latte/UIMacros.link.2.phpt b/tests/Bridges.Latte/UIMacros.link.2.phpt
-index c1d88ea..a7d8421 100644
---- a/tests/Bridges.Latte/UIMacros.link.2.phpt
-+++ b/tests/Bridges.Latte/UIMacros.link.2.phpt
-@@ -87,7 +87,7 @@ link:['login']
- <a href="link:['default!#hash',10,20]"></a>
- EOD
-
--, $latte->renderToString(<<<EOD
-+, strtr($latte->renderToString(<<<EOD
- {plink Homepage:}
-
- {plink Homepage: }
-@@ -118,4 +118,4 @@ EOD
-
- <a n:href="default!#hash 10, 20"></a>
- EOD
--, $params));
-+, $params), ['&#039;' => "'"]));