summaryrefslogtreecommitdiffstats
path: root/php-latte.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-05-22 06:43:57 +0200
committerRemi Collet <remi@remirepo.net>2017-05-22 06:43:57 +0200
commitda362bc42828902d7a906edb1880b9314b169814 (patch)
tree9b72e16ca88cbb0a734c48a4ebf5f0ba7875def2 /php-latte.spec
parentf66b53a268b0bc42b6d64a8cb00250bb6675d4af (diff)
switch the spec
Diffstat (limited to 'php-latte.spec')
-rw-r--r--php-latte.spec79
1 files changed, 53 insertions, 26 deletions
diff --git a/php-latte.spec b/php-latte.spec
index 4a65483..90a602b 100644
--- a/php-latte.spec
+++ b/php-latte.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 995521e5ce0dc99ce8c801cba4c19322878f0a98
+%global gh_commit b62ee346467e1e2402a43c499cf6047fddc5d321
#global gh_date 20150728
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nette
@@ -16,7 +16,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.3.13
+Version: 2.4.3
%global specrel 1
Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Latte: the amazing template engine for PHP
@@ -32,7 +32,7 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-composer(theseer/autoload)
%if %{with_tests}
-BuildRequires: php(language) >= 5.3.1
+BuildRequires: php(language) >= 5.4.4
BuildRequires: php-tokenizer
BuildRequires: php-date
BuildRequires: php-fileinfo
@@ -42,25 +42,39 @@ BuildRequires: php-mbstring
BuildRequires: php-pcre
BuildRequires: php-reflection
BuildRequires: php-spl
+BuildRequires: php-tokenizer
+BuildRequires: php-xml
# From composer.json, "require-dev": {
-# "nette/tester": "~1.3"
-BuildRequires: php-composer(%{gh_owner}/tester) >= 1.3
+# "nette/tester": "~2.0",
+# "tracy/tracy": "^2.3"
+# ignore tester min version (pass with 1.7), ignore tracy (pass without)
+BuildRequires: php-composer(%{gh_owner}/tester) >= 1.7
%endif
# from composer.json, "require": {
-# "php": ">=5.3.1"
+# "php": ">=5.4.4"
+# "ext-json": "*",
# "ext-tokenizer": "*"
-Requires: php(language) >= 5.3.1
+Requires: php(language) >= 5.4.4
+Requires: php-json
Requires: php-tokenizer
-# from phpcompatinfo report for version 2.3.6
-Requires: php-date
+# from composer.json, "suggest": {
+# "ext-mbstring": "to use filters like lower, upper, capitalize, ...",
+# "ext-fileinfo": "to use filter |datastream",
+# "ext-xml": "to use filters like length, substring, ..."
Requires: php-fileinfo
-Requires: php-iconv
-Requires: php-json
Requires: php-mbstring
+Requires: php-xml
+# from composer.json, "conflict": {
+# "nette/application": "<2.4"
+Conflicts: php-composer(%{gh_owner}/application) < 2.4.1
+# from phpcompatinfo report for version 2.4.1
+Requires: php-date
+Requires: php-iconv
Requires: php-pcre
Requires: php-reflection
Requires: php-spl
+Requires: php-tokenizer
# provides latte/latte
Provides: php-composer(%{gh_project}/%{gh_project}) = %{version}
@@ -101,16 +115,8 @@ cp -pr src/* %{buildroot}%{php_home}/
%check
%if %{with_tests}
-: Ignore failed test under investigation
-rm 'tests/Latte/Helpers.optimizePhp().phpt'
-
-: Generate configuration
-cat /etc/php.ini /etc/php.d/*ini >php.ini
export LANG=fr_FR.utf8
-: For PHP 5.3.3 on RHEL-6
-sed -e 's/50303/99999/' -i tests/Latte/Object.phpt
-
: Generate autoloader
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
@@ -120,12 +126,23 @@ require_once '%{buildroot}%{php_home}/%{ns_vendor}/autoload.php';
EOF
: Run test suite in sources tree
-%{_bindir}/nette-tester --colors 0 -p php -c ./php.ini tests -s
-
-if which php70; then
- cat /etc/opt/remi/php70/php.ini /etc/opt/remi/php70/php.d/*ini >php.ini
- php70 %{_bindir}/nette-tester --colors 0 -p php70 -c ./php.ini tests -s
+# remirepo:12
+ret=0
+run=0
+if which php56; then
+ php56 %{_bindir}/nette-tester --colors 0 -p php56 -C -s || ret=1
+ run=1
+fi
+if which php71; then
+ rm tests/Latte/Filters.general.phpt
+ php71 %{_bindir}/nette-tester --colors 0 -p php71 -C -s || ret=1
+ run=1
fi
+if [ $run -eq 0 ]; then
+%{_bindir}/nette-tester --colors 0 -p php -C tests -s
+# remirepo:2
+fi
+exit $ret
%else
: Test suite disabled
%endif
@@ -145,8 +162,18 @@ rm -rf %{buildroot}
%changelog
-* Wed Dec 21 2016 Remi Collet <remi@fedoraproject.org> - 2.3.13-1
-- update to 2.3.13
+* Thu Jan 19 2017 Remi Collet <remi@fedoraproject.org> - 2.4.3-1
+- update to 2.4.3
+
+* Wed Sep 28 2016 Remi Collet <remi@fedoraproject.org> - 2.4.2-1
+- update to 2.4.2
+
+* Thu Aug 4 2016 Remi Collet <remi@fedoraproject.org> - 2.4.1-1
+- update to 2.4.1
+
+* Fri Jul 1 2016 Remi Collet <remi@fedoraproject.org> - 2.4.0-1
+- update to 2.4.0
+- raise dependency on php >= 5.4.4
* Mon May 30 2016 Remi Collet <remi@fedoraproject.org> - 2.3.12-1
- update to 2.3.12