summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-07-01 15:43:52 +0200
committerRemi Collet <fedora@famillecollet.com>2016-07-01 15:43:52 +0200
commitca9f3758ed3b6910abb8b0b3993398a61342bea9 (patch)
treee1abec861d16d371cb3df1c20ad4e751e3c46c8f
parent374ba248723289b057a6a463c4527e0659eadd26 (diff)
php-latte: 2.4.0 (wip, missing dep)
-rw-r--r--composer-dev.json41
-rwxr-xr-xmakesrc.sh17
-rw-r--r--php-latte-dev.spec20
3 files changed, 66 insertions, 12 deletions
diff --git a/composer-dev.json b/composer-dev.json
new file mode 100644
index 0000000..f13a746
--- /dev/null
+++ b/composer-dev.json
@@ -0,0 +1,41 @@
+{
+ "name": "latte/latte",
+ "description": "Latte: the amazing template engine for PHP",
+ "keywords": ["templating", "twig"],
+ "homepage": "https://latte.nette.org",
+ "license": ["BSD-3-Clause", "GPL-2.0", "GPL-3.0"],
+ "authors": [
+ {
+ "name": "David Grudl",
+ "homepage": "https://davidgrudl.com"
+ },
+ {
+ "name": "Nette Community",
+ "homepage": "https://nette.org/contributors"
+ }
+ ],
+ "require": {
+ "php": ">=5.4.4",
+ "ext-tokenizer": "*"
+ },
+ "require-dev": {
+ "nette/tester": "~2.0",
+ "tracy/tracy": "^2.3"
+ },
+ "suggest": {
+ "ext-mbstring": "to use filters like lower, upper, capitalize, ...",
+ "ext-fileinfo": "to use filter |datastream"
+ },
+ "conflict": {
+ "nette/application": "<2.4"
+ },
+ "autoload": {
+ "classmap": ["src/"]
+ },
+ "minimum-stability": "dev",
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.4-dev"
+ }
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
index 87d223d..32df0cc 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -1,10 +1,17 @@
#!/bin/bash
NAME=$(basename $PWD)
-OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
-PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
-VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
-COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+if [ "$1" = "dev" ]; then
+SPEC=$NAME-dev.spec
+COMP=composer-dev.json
+else
+SPEC=$NAME.spec
+COMP=composer.json
+fi
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $SPEC)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $SPEC)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $SPEC)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $SPEC)
SHORT=${COMMIT:0:7}
echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
@@ -16,7 +23,7 @@ git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
echo "Getting commit..."
pushd $PROJECT-$COMMIT
git checkout $COMMIT
-cp composer.json ../composer.json
+cp composer.json ../$COMP
popd
echo "Archiving..."
diff --git a/php-latte-dev.spec b/php-latte-dev.spec
index 220a9f4..1940f11 100644
--- a/php-latte-dev.spec
+++ b/php-latte-dev.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 26af8b6b68ea68bb466ce692c12b8898524456bd
+%global gh_commit 2c45c382f50cc981019628c9b074ad257207fb09
#global gh_date 20150728
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nette
@@ -16,7 +16,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.3.12
+Version: 2.4.0
%global specrel 1
Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Latte: the amazing template engine for PHP
@@ -32,7 +32,7 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-composer(theseer/autoload)
%if %{with_tests}
-BuildRequires: php(language) >= 5.3.1
+BuildRequires: php(language) >= 5.4.4
BuildRequires: php-tokenizer
BuildRequires: php-date
BuildRequires: php-fileinfo
@@ -43,14 +43,16 @@ BuildRequires: php-pcre
BuildRequires: php-reflection
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "nette/tester": "~1.3"
-BuildRequires: php-composer(%{gh_owner}/tester) >= 1.3
+# "nette/tester": "~2.0",
+# "tracy/tracy": "^2.3"
+BuildRequires: php-composer(%{gh_owner}/tester) >= 2.0
+BuildRequires: php-composer(tracy/tracy) >= 2.3
%endif
# from composer.json, "require": {
-# "php": ">=5.3.1"
+# "php": ">=5.4.4"
# "ext-tokenizer": "*"
-Requires: php(language) >= 5.3.1
+Requires: php(language) >= 5.4.4
Requires: php-tokenizer
# from phpcompatinfo report for version 2.3.6
Requires: php-date
@@ -145,6 +147,10 @@ rm -rf %{buildroot}
%changelog
+* Fri Jul 1 2016 Remi Collet <remi@fedoraproject.org> - 2.4.0-1
+- update to 2.4.0
+- raise dependency on php >= 5.4.4
+
* Mon May 30 2016 Remi Collet <remi@fedoraproject.org> - 2.3.12-1
- update to 2.3.12