summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-08-04 10:39:47 +0200
committerRemi Collet <fedora@famillecollet.com>2016-08-04 10:39:47 +0200
commit4600527dc8b698b887aad7f0e82624a10985e1c3 (patch)
treeae4de4d1161322890572d4f7fca4c5cea7f0443d
parentc9d90a2ddd9c08ed3ff82623c25cbea249aff347 (diff)
php-latte: 2.4.1
-rw-r--r--composer-dev.json6
-rwxr-xr-xmakesrc.sh17
-rw-r--r--php-latte-dev.spec25
3 files changed, 28 insertions, 20 deletions
diff --git a/composer-dev.json b/composer-dev.json
index f13a746..384f9b4 100644
--- a/composer-dev.json
+++ b/composer-dev.json
@@ -16,6 +16,7 @@
],
"require": {
"php": ">=5.4.4",
+ "ext-json": "*",
"ext-tokenizer": "*"
},
"require-dev": {
@@ -24,10 +25,11 @@
},
"suggest": {
"ext-mbstring": "to use filters like lower, upper, capitalize, ...",
- "ext-fileinfo": "to use filter |datastream"
+ "ext-fileinfo": "to use filter |datastream",
+ "ext-xml": "to use filters like length, substring, ..."
},
"conflict": {
- "nette/application": "<2.4"
+ "nette/application": "<2.4.1"
},
"autoload": {
"classmap": ["src/"]
diff --git a/makesrc.sh b/makesrc.sh
index 32df0cc..2070e27 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -1,17 +1,10 @@
#!/bin/bash
NAME=$(basename $PWD)
-if [ "$1" = "dev" ]; then
-SPEC=$NAME-dev.spec
-COMP=composer-dev.json
-else
-SPEC=$NAME.spec
-COMP=composer.json
-fi
-OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $SPEC)
-PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $SPEC)
-VERSION=$(sed -n '/^Version:/{s/.* //;p}' $SPEC)
-COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $SPEC)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME$1.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME$1.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME$1.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME$1.spec)
SHORT=${COMMIT:0:7}
echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
@@ -23,7 +16,7 @@ git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
echo "Getting commit..."
pushd $PROJECT-$COMMIT
git checkout $COMMIT
-cp composer.json ../$COMP
+cp composer.json ../composer$1.json
popd
echo "Archiving..."
diff --git a/php-latte-dev.spec b/php-latte-dev.spec
index 64d7def..52346e9 100644
--- a/php-latte-dev.spec
+++ b/php-latte-dev.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 2c45c382f50cc981019628c9b074ad257207fb09
+%global gh_commit 08efb9414d847643848932ef8163d5b66d6d0380
#global gh_date 20150728
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nette
@@ -16,7 +16,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.4.0
+Version: 2.4.1
%global specrel 1
Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Latte: the amazing template engine for PHP
@@ -43,6 +43,7 @@ BuildRequires: php-pcre
BuildRequires: php-reflection
BuildRequires: php-spl
BuildRequires: php-tokenizer
+BuildRequires: php-xml
# From composer.json, "require-dev": {
# "nette/tester": "~2.0",
# "tracy/tracy": "^2.3"
@@ -52,15 +53,24 @@ BuildRequires: php-composer(%{gh_owner}/tester) >= 1.7
# from composer.json, "require": {
# "php": ">=5.4.4"
+# "ext-json": "*",
# "ext-tokenizer": "*"
Requires: php(language) >= 5.4.4
+Requires: php-json
Requires: php-tokenizer
-# from phpcompatinfo report for version 2.4.0
-Requires: php-date
+# from composer.json, "suggest": {
+# "ext-mbstring": "to use filters like lower, upper, capitalize, ...",
+# "ext-fileinfo": "to use filter |datastream",
+# "ext-xml": "to use filters like length, substring, ..."
Requires: php-fileinfo
-Requires: php-iconv
-Requires: php-json
Requires: php-mbstring
+Requires: php-xml
+# from composer.json, "conflict": {
+# "nette/application": "<2.4"
+Conflicts: php-composer(%{gh_owner}/application) < 2.4.1
+# from phpcompatinfo report for version 2.4.1
+Requires: php-date
+Requires: php-iconv
Requires: php-pcre
Requires: php-reflection
Requires: php-spl
@@ -156,6 +166,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Aug 4 2016 Remi Collet <remi@fedoraproject.org> - 2.4.1-1
+- update to 2.4.1
+
* Fri Jul 1 2016 Remi Collet <remi@fedoraproject.org> - 2.4.0-1
- update to 2.4.0
- raise dependency on php >= 5.4.4