summaryrefslogtreecommitdiffstats
path: root/php-netresearch-jsonmapper.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-netresearch-jsonmapper.spec')
-rw-r--r--php-netresearch-jsonmapper.spec5
1 files changed, 2 insertions, 3 deletions
diff --git a/php-netresearch-jsonmapper.spec b/php-netresearch-jsonmapper.spec
index 6cad459..f90701d 100644
--- a/php-netresearch-jsonmapper.spec
+++ b/php-netresearch-jsonmapper.spec
@@ -22,7 +22,6 @@ Version: 1.4.0
Release: 1%{?dist}
Summary: Map nested JSON structures onto PHP classes
-Group: Development/Libraries
License: OSL 3.0
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{name}-%{version}-%{gh_short}.tgz
@@ -38,7 +37,7 @@ BuildRequires: php-spl
# From composer.json, "require-dev": {
# "phpunit/phpunit": "~4.8.35 || ~5.7 || ~6.4",
# "squizlabs/php_codesniffer": "~1.5"
-%if 0%{?fedora} >= 26
+%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
%global phpunit %{_bindir}/phpunit6
BuildRequires: phpunit6 >= 6.4
%else
@@ -100,7 +99,7 @@ mkdir vendor
: Run upstream test suite
ret=0
-for cmd in "php %{phpunit}" php70 php71 php72; do
+for cmd in "php %{phpunit}" php70 php71 php72 php73; do
if which $cmd; then
set $cmd
$1 ${2:-%{_bindir}/phpunit6} \