summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-01-22 12:24:39 +0100
committerRemi Collet <remi@remirepo.net>2018-01-22 12:24:39 +0100
commit98cf6c100498b3c90c204755a12412b739b8e565 (patch)
treef672af0414a053e08040fa61485b96a1d66a32d5
parente968f5a595210fb7579f4b95b548b677122a6796 (diff)
Update to 1.4.0
use phpunit6 on F26+ sources from git snapshot
-rw-r--r--composer.json2
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-netresearch-jsonmapper.spec34
3 files changed, 55 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index 4c3b314..de7817d 100644
--- a/composer.json
+++ b/composer.json
@@ -21,7 +21,7 @@
"php": ">=5.6"
},
"require-dev": {
- "phpunit/phpunit": "4.2.*",
+ "phpunit/phpunit": "~4.8.35 || ~5.7 || ~6.4",
"squizlabs/php_codesniffer": "~1.5"
}
}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..87d223d
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-netresearch-jsonmapper.spec b/php-netresearch-jsonmapper.spec
index 2c82c16..6cad459 100644
--- a/php-netresearch-jsonmapper.spec
+++ b/php-netresearch-jsonmapper.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-netresearch-jsonmapper
#
-# Copyright (c) 2017 Remi Collet
+# Copyright (c) 2017-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit b94ffe5b237a697253f06f5a57d9b22292bfffb3
+%global gh_commit 3868fe1128ce1169228acdb623359dca74db5ef3
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner cweiske
%global gh_project jsonmapper
@@ -18,14 +18,16 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{pk_vendor}-%{pk_project}
-Version: 1.3.0
+Version: 1.4.0
Release: 1%{?dist}
Summary: Map nested JSON structures onto PHP classes
Group: Development/Libraries
License: OSL 3.0
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+Source0: %{name}-%{version}-%{gh_short}.tgz
+# Git snapshot with tests
+Source1: makesrc.sh
BuildArch: noarch
%if %{with_tests}
@@ -34,9 +36,15 @@ BuildRequires: php(language) >= 5.6
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "4.2.*",
+# "phpunit/phpunit": "~4.8.35 || ~5.7 || ~6.4",
# "squizlabs/php_codesniffer": "~1.5"
-BuildRequires: php-composer(phpunit/phpunit) >= 4.2
+%if 0%{?fedora} >= 26
+%global phpunit %{_bindir}/phpunit6
+BuildRequires: phpunit6 >= 6.4
+%else
+%global phpunit %{_bindir}/phpunit
+BuildRequires: php-phpunit-PHPUnit >= 4.8.35
+%endif
# Required by autoloader
BuildRequires: php-fedora-autoloader-devel
%endif
@@ -90,10 +98,15 @@ cp -pr src %{buildroot}%{php_home}/%{pk_vendor}/%{pk_project}
%if %{with_tests}
mkdir vendor
+: Run upstream test suite
ret=0
-for cmd in php php56 php70 php71 php72; do
+for cmd in "php %{phpunit}" php70 php71 php72; do
if which $cmd; then
- $cmd %{_bindir}/phpunit --bootstrap %{buildroot}%{php_home}/%{pk_vendor}/%{pk_project}/autoload.php --verbose . || ret=1
+ set $cmd
+ $1 ${2:-%{_bindir}/phpunit6} \
+ --bootstrap %{buildroot}%{php_home}/%{pk_vendor}/%{pk_project}/autoload.php \
+ --no-coverage \
+ --verbose . || ret=1
fi
done
exit $ret
@@ -112,5 +125,10 @@ exit $ret
%changelog
+* Mon Jan 22 2018 Remi Collet <remi@remirepo.net> - 1.4.0-1
+- Update to 1.4.0
+- use phpunit6 on F26+
+- sources from git snapshot
+
* Sat Oct 21 2017 Remi Collet <remi@remirepo.net> - 1.3.0-1
- initial package, version 1.3.0