summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-03-14 15:56:52 +0100
committerRemi Collet <remi@remirepo.net>2020-03-14 15:56:52 +0100
commit70ddf7432c6a6e65b9a0e2d80057596730b918d8 (patch)
treebf497a83d5f30e40ad959c0a5dd68ebeffda0eb6
parent17f49c6686f6b62f7306523948f125638c17b1cb (diff)
update to 2.0.0
switch to phpunit7
-rw-r--r--composer.json4
-rw-r--r--php-netresearch-jsonmapper.spec25
2 files changed, 14 insertions, 15 deletions
diff --git a/composer.json b/composer.json
index 305b2d5..b6d2777 100644
--- a/composer.json
+++ b/composer.json
@@ -25,7 +25,7 @@
"ext-reflection": "*"
},
"require-dev": {
- "phpunit/phpunit": "~4.8.35 || ~5.7 || ~6.4",
- "squizlabs/php_codesniffer": "~1.5"
+ "phpunit/phpunit": "~4.8.35 || ~5.7 || ~6.4 || ~7.0",
+ "squizlabs/php_codesniffer": "~3.5"
}
}
diff --git a/php-netresearch-jsonmapper.spec b/php-netresearch-jsonmapper.spec
index f5d775d..07f287f 100644
--- a/php-netresearch-jsonmapper.spec
+++ b/php-netresearch-jsonmapper.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 0d4d1b48d682a93b6bfedf60b88c7750e9cb0b06
+%global gh_commit e245890383c3ed38b6d202ee373c23ccfebc0f54
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner cweiske
%global gh_project jsonmapper
@@ -18,7 +18,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{pk_vendor}-%{pk_project}
-Version: 1.6.0
+Version: 2.0.0
Release: 1%{?dist}
Summary: Map nested JSON structures onto PHP classes
@@ -37,15 +37,10 @@ BuildRequires: php-json
BuildRequires: php-pcre
BuildRequires: php-reflection
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "~4.8.35 || ~5.7 || ~6.4",
-# "squizlabs/php_codesniffer": "~1.5"
-%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
-%global phpunit %{_bindir}/phpunit6
-BuildRequires: phpunit6 >= 6.4
-%else
-%global phpunit %{_bindir}/phpunit
-BuildRequires: php-phpunit-PHPUnit >= 4.8.35
-%endif
+# "phpunit/phpunit": "~4.8.35 || ~5.7 || ~6.4 || ~7.0",
+# "squizlabs/php_codesniffer": "~3.5"
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7
# Required by autoloader
BuildRequires: php-fedora-autoloader-devel
%endif
@@ -108,10 +103,10 @@ mkdir vendor
: Run upstream test suite
ret=0
-for cmd in "php %{phpunit}" php71 php72 php73 php74; do
+for cmd in "php %{phpunit}" php72 php73 php74; do
if which $cmd; then
set $cmd
- $1 ${2:-%{_bindir}/phpunit6} \
+ $1 ${2:-%{_bindir}/phpunit7} \
--bootstrap %{buildroot}%{php_home}/%{pk_vendor}/%{pk_project}/autoload.php \
--no-coverage \
--verbose . || ret=1
@@ -133,6 +128,10 @@ exit $ret
%changelog
+* Sat Mar 14 2020 Remi Collet <remi@remirepo.net> - 2.0.0-1
+- update to 2.0.0
+- switch to phpunit7
+
* Mon Aug 19 2019 Remi Collet <remi@remirepo.net> - 1.6.0-1
- update to 1.6.0
- drop patch merged upstream