summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore8
-rw-r--r--php-natxet-cssmin.spec26
2 files changed, 22 insertions, 12 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/php-natxet-cssmin.spec b/php-natxet-cssmin.spec
index b8105e9..805ac32 100644
--- a/php-natxet-cssmin.spec
+++ b/php-natxet-cssmin.spec
@@ -9,8 +9,8 @@
#
%global github_owner natxet
%global github_name CssMin
-%global github_version 3.0.4
-%global github_commit 92de3fe3ccb4f8298d31952490ef7d5395855c39
+%global github_version 3.0.6
+%global github_commit d5d9f4c3e5cedb1ae96a95a21731f8790e38f1dd
# if set, will be a post-release snapshot build, otherwise a 'normal' build
#global github_date 20141229
%global shortcommit %(c=%{github_commit}; echo ${c:0:7})
@@ -24,10 +24,9 @@
Name: php-%{packagist_owner}-%{lcname}
Version: %{github_version}
-Release: 3%{?github_date:.%{github_date}git%{shortcommit}}%{?dist}
+Release: 1%{?github_date:.%{github_date}git%{shortcommit}}%{?dist}
Summary: Configurable CSS parser and minifier
-Group: Development/Libraries
# License text is included in the sole code file
License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
@@ -35,8 +34,9 @@ URL: https://github.com/%{github_owner}/%{github_name}
# https://fedoraproject.org/wiki/Packaging:SourceURL#Github
Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{github_name}-%{github_commit}.tar.gz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
+BuildRequires: php-cli
+BuildRequires: php-pcre
Requires: php(language) >= %{php_min_ver}
Requires: php-pcre
@@ -64,27 +64,29 @@ shorter notation if available. The minification is configurable.
%install
-rm -rf %{buildroot}
mkdir -p %{buildroot}%{_datadir}/php/%{packagist_owner}/%{packagist_name}
cp -pr src/ %{buildroot}%{_datadir}/php/%{packagist_owner}/%{packagist_name}
cp -p autoload.php %{buildroot}%{_datadir}/php/%{packagist_owner}/%{packagist_name}
-%clean
-rm -rf %{buildroot}
-
-
%check
-# no tests
+# Minimal test for our autoloader
+php -r '
+ require "%{buildroot}%{_datadir}/php/%{packagist_owner}/%{packagist_name}/autoload.php";
+ exit(class_exists("CssMin") ? 0 : 1);
+'
%files
-%defattr(-,root,root,-)
%doc README composer.json
%{_datadir}/php/%{packagist_owner}
%changelog
+* Tue Mar 26 2019 Remi Collet <remi@remirepo.net> - 3.0.6-1
+- update to 3.0.6
+- add minimal test for our autoloader
+
* Tue May 3 2016 Remi Collet <remi@fedoraproject.org> - 3.0.4-3
- rebuild