summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-02-24 09:06:55 +0100
committerRemi Collet <fedora@famillecollet.com>2015-02-24 09:06:55 +0100
commit574ab7d3057138f6d5d61266d4aec1531947e83a (patch)
tree4025abeba36914a07a0eb1b3f6468f1945699105
php-natxet-cssmin: import from rawhide
-rw-r--r--php-natxet-cssmin.spec71
1 files changed, 71 insertions, 0 deletions
diff --git a/php-natxet-cssmin.spec b/php-natxet-cssmin.spec
new file mode 100644
index 0000000..64c5677
--- /dev/null
+++ b/php-natxet-cssmin.spec
@@ -0,0 +1,71 @@
+%global github_owner natxet
+%global github_name CssMin
+%global github_version 3.0.2
+%global github_commit 8883d28cd2de131c364f2f657e4bcc09bfa45082
+# if set, will be a post-release snapshot build, otherwise a 'normal' build
+%global github_date 20141229
+%global shortcommit %(c=%{github_commit}; echo ${c:0:7})
+%global packagist_owner natxet
+%global packagist_name CssMin
+
+%global lcname %(echo %{packagist_name} | tr '[:upper:]' '[:lower:]')
+
+# phpci
+%global php_min_ver 5.0.0
+
+Name: php-%{packagist_owner}-%{lcname}
+Version: %{github_version}
+Release: 2%{?github_date:.%{github_date}git%{shortcommit}}%{?dist}
+Summary: Configurable CSS parser and minifier
+
+Group: Development/Libraries
+# License text is included in the sole code file
+License: MIT
+URL: https://github.com/%{github_owner}/%{github_name}
+# Must use commit-based not tag-based github tarball:
+# https://fedoraproject.org/wiki/Packaging:SourceURL#Github
+Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{github_name}-%{github_commit}.tar.gz
+
+BuildArch: noarch
+
+Requires: php(language) >= %{php_min_ver}
+Requires: php-pcre
+
+Provides: php-composer(%{packagist_owner}/%{packagist_name}) = %{version}
+
+
+%description
+CssMin is a css parser and minifier. It minifies css by removing
+unneeded whitespace characters, comments, empty blocks and empty
+declarations. In addition declaration values can get rewritten to
+shorter notation if available. The minification is configurable.
+
+
+%prep
+%setup -qn %{github_name}-%{github_commit}
+
+
+%build
+# Empty build section, nothing required
+
+
+%install
+mkdir -p %{buildroot}%{_datadir}/php/%{packagist_owner}/%{packagist_name}
+cp -pr src/ %{buildroot}%{_datadir}/php/%{packagist_owner}/%{packagist_name}
+
+
+%check
+# no tests
+
+
+%files
+%doc README composer.json
+%{_datadir}/php/%{packagist_owner}
+
+
+%changelog
+* Mon Feb 23 2015 Adam Williamson <awilliam@redhat.com> - 3.0.2-2.20141229git8883d28
+- change layout to match upstream's (with the /src sub-directory)
+
+* Mon Dec 29 2014 Adam Williamson <awilliam@redhat.com> - 3.0.2-1.20141229git8883d28
+- initial package