summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-myclabs-php-enum.spec20
2 files changed, 11 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index 88bbe16..3a10886 100644
--- a/composer.json
+++ b/composer.json
@@ -22,7 +22,7 @@
}
},
"require": {
- "php": ">=5.4",
+ "php": ">=7.2",
"ext-json": "*"
},
"require-dev": {
diff --git a/php-myclabs-php-enum.spec b/php-myclabs-php-enum.spec
index 0e38768..8c9426f 100644
--- a/php-myclabs-php-enum.spec
+++ b/php-myclabs-php-enum.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 32c4202886c51fbe5cc3a7c34ec5c9a4a790345e
+%global gh_commit e00b7b3d8d2ef0da908ea9d3df627271b93a9253
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner myclabs
%global gh_project php-enum
@@ -20,7 +20,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{pk_vendor}-%{pk_project}
-Version: 1.6.6
+Version: 1.7.0
Release: 1%{?dist}
Summary: PHP Enum implementation
@@ -33,27 +33,23 @@ Source1: makesrc.sh
BuildArch: noarch
%if %{with_tests}
# For tests
-BuildRequires: php(language) >= 5.4
+BuildRequires: php(language) >= 7.2
BuildRequires: php-reflection
BuildRequires: php-json
BuildRequires: php-spl
# From composer.json, "require-dev": {
# "phpunit/phpunit": "^4.8.35|^5.7|^6.0",
# "squizlabs/php_codesniffer": "1.*"
-%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
%global phpunit %{_bindir}/phpunit6
-%else
-%global phpunit %{_bindir}/phpunit
-%endif
BuildRequires: %{phpunit}
# Required by autoloader
BuildRequires: php-composer(fedora/autoloader)
%endif
# From composer.json, "require": {
-# "php": ">=5.4",
+# "php": ">=7.2",
# "ext-json": "*"
-Requires: php(language) >= 5.4
+Requires: php(language) >= 7.2
Requires: php-json
# From phpcompatinfo report for version 1.6.1
Requires: php-reflection
@@ -101,7 +97,7 @@ require '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php';
EOF
ret=0
-for cmd in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72 php73; do
+for cmd in "php %{phpunit}" php72 php73; do
if which $cmd; then
set $cmd
$1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
@@ -123,6 +119,10 @@ exit $ret
%changelog
+* Wed Apr 24 2019 Remi Collet <remi@remirepo.net> - 1.7.0-1
+- update to 1.7.0
+- raise dependency on PHP 7.2
+
* Tue Feb 5 2019 Remi Collet <remi@remirepo.net> - 1.6.6-1
- update to 1.6.6