summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json5
-rw-r--r--php-myclabs-php-enum.spec22
2 files changed, 19 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 924f924..978cb19 100644
--- a/composer.json
+++ b/composer.json
@@ -14,7 +14,10 @@
"autoload": {
"psr-4": {
"MyCLabs\\Enum\\": "src/"
- }
+ },
+ "classmap": [
+ "stubs/Stringable.php"
+ ]
},
"autoload-dev": {
"psr-4": {
diff --git a/php-myclabs-php-enum.spec b/php-myclabs-php-enum.spec
index 022b716..eda4add 100644
--- a/php-myclabs-php-enum.spec
+++ b/php-myclabs-php-enum.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-myclabs-php-enum
#
-# Copyright (c) 2017-2021 Remi Collet
+# Copyright (c) 2017-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit b942d263c641ddb5190929ff840c68f78713e937
+%global gh_commit a867478eae49c9f59ece437ae7f9506bfaa27483
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner myclabs
%global gh_project php-enum
@@ -17,10 +17,11 @@
%global ns_vendor MyCLabs
%global ns_project Enum
%global php_home %{_datadir}/php
-%global with_tests 0%{!?_without_tests:1}
+
+%bcond_without tests
Name: php-%{pk_vendor}-%{pk_project}
-Version: 1.8.3
+Version: 1.8.4
Release: 1%{?dist}
Summary: PHP Enum implementation
@@ -31,7 +32,7 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
BuildArch: noarch
-%if %{with_tests}
+%if %{with tests}
# For tests
BuildRequires: php(language) >= 7.3
BuildRequires: php-reflection
@@ -70,11 +71,14 @@ Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}/autoload.php
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+mv stubs/Stringable.php src/
+
cat << 'EOF' | tee src/autoload.php
<?php
/* Autoloader for %{name} and its dependencies */
require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('%{ns_vendor}\\%{ns_project}\\', __DIR__);
+require_once __DIR__ . '/Stringable.php';
EOF
@@ -89,7 +93,7 @@ cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}
%check
-%if %{with_tests}
+%if %{with tests}
mkdir vendor
cat << 'EOF' | tee tests/autoload.php
<?php
@@ -99,7 +103,7 @@ require __DIR__ . '/bootstrap.php';
EOF
ret=0
-for cmd in "php %{phpunit}" php73 php74 php80 php81; do
+for cmd in "php %{phpunit}" php74 php80 php81 php82; do
if which $cmd; then
set $cmd
$1 ${2:-%{_bindir}/phpunit9} --verbose --bootstrap tests/autoload.php || ret=1
@@ -112,6 +116,7 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
@@ -121,6 +126,9 @@ exit $ret
%changelog
+* Thu Aug 4 2022 Remi Collet <remi@remirepo.net> - 1.8.4-1
+- update to 1.8.4
+
* Mon Jul 5 2021 Remi Collet <remi@remirepo.net> - 1.8.3-1
- update to 1.8.3