summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-05-06 09:09:07 +0200
committerRemi Collet <remi@remirepo.net>2019-05-06 09:09:07 +0200
commit94da6cc913d0b2869a8881dd12e0dbc711ca0e3d (patch)
treeb5502aa3e86c6233e874e043c71cb18c62b26035
parent94d106e32a5543aea3121fc5cb066c8208a34cd6 (diff)
v1.7.1
-rw-r--r--composer.json2
-rw-r--r--php-myclabs-php-enum.spec21
2 files changed, 14 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index 3a10886..871156d 100644
--- a/composer.json
+++ b/composer.json
@@ -22,7 +22,7 @@
}
},
"require": {
- "php": ">=7.2",
+ "php": ">=7.1",
"ext-json": "*"
},
"require-dev": {
diff --git a/php-myclabs-php-enum.spec b/php-myclabs-php-enum.spec
index 8c9426f..86e844e 100644
--- a/php-myclabs-php-enum.spec
+++ b/php-myclabs-php-enum.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit e00b7b3d8d2ef0da908ea9d3df627271b93a9253
+%global gh_commit f46847626b8739de22e4ebc6b56010f317d4448d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner myclabs
%global gh_project php-enum
@@ -20,7 +20,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{pk_vendor}-%{pk_project}
-Version: 1.7.0
+Version: 1.7.1
Release: 1%{?dist}
Summary: PHP Enum implementation
@@ -33,7 +33,7 @@ Source1: makesrc.sh
BuildArch: noarch
%if %{with_tests}
# For tests
-BuildRequires: php(language) >= 7.2
+BuildRequires: php(language) >= 7.1
BuildRequires: php-reflection
BuildRequires: php-json
BuildRequires: php-spl
@@ -47,9 +47,9 @@ BuildRequires: php-composer(fedora/autoloader)
%endif
# From composer.json, "require": {
-# "php": ">=7.2",
+# "php": ">=7.1",
# "ext-json": "*"
-Requires: php(language) >= 7.2
+Requires: php(language) >= 7.1
Requires: php-json
# From phpcompatinfo report for version 1.6.1
Requires: php-reflection
@@ -90,17 +90,18 @@ cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}
%check
%if %{with_tests}
mkdir vendor
-cat << 'EOF' | tee vendor/autoload.php
+cat << 'EOF' | tee tests/autoload.php
<?php
require '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('%{ns_vendor}\\Tests\\%{ns_project}\\', __DIR__ . '/../tests');
+require __DIR__ . '/bootstrap.php';
EOF
ret=0
-for cmd in "php %{phpunit}" php72 php73; do
+for cmd in "php %{phpunit}" php71 php72 php73; do
if which $cmd; then
set $cmd
- $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit6} --verbose --bootstrap tests/autoload.php || ret=1
fi
done
exit $ret
@@ -119,6 +120,10 @@ exit $ret
%changelog
+* Mon May 6 2019 Remi Collet <remi@remirepo.net> - 1.7.1-1
+- update to 1.7.1
+- lower dependency on PHP 7.1
+
* Wed Apr 24 2019 Remi Collet <remi@remirepo.net> - 1.7.0-1
- update to 1.7.0
- raise dependency on PHP 7.2