summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-02-07 13:20:54 +0100
committerRemi Collet <remi@remirepo.net>2020-02-07 13:20:54 +0100
commit57087ebf208f97c694bfdabdeac9d5c06419e035 (patch)
treeeeebb763006b62c7e5858bc734f7aaedb76bcdf5
parentf7e1a6545c12acc0f0396bd254569202afaeecee (diff)
update to 1.7.4
switch to phpunit7
-rw-r--r--composer.json5
-rw-r--r--php-myclabs-php-enum.spec15
2 files changed, 13 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index 871156d..6861a5c 100644
--- a/composer.json
+++ b/composer.json
@@ -26,7 +26,8 @@
"ext-json": "*"
},
"require-dev": {
- "phpunit/phpunit": "^4.8.35|^5.7|^6.0",
- "squizlabs/php_codesniffer": "1.*"
+ "phpunit/phpunit": "^7",
+ "squizlabs/php_codesniffer": "1.*",
+ "vimeo/psalm": "^3.8"
}
}
diff --git a/php-myclabs-php-enum.spec b/php-myclabs-php-enum.spec
index e5339f2..504ada8 100644
--- a/php-myclabs-php-enum.spec
+++ b/php-myclabs-php-enum.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-myclabs-php-enum
#
-# Copyright (c) 2017-2019 Remi Collet
+# Copyright (c) 2017-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 45f01adf6922df6082bcda36619deb466e826acf
+%global gh_commit c3f3b36602748871098069f4f2f8224ca34df899
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner myclabs
%global gh_project php-enum
@@ -20,7 +20,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{pk_vendor}-%{pk_project}
-Version: 1.7.2
+Version: 1.7.4
Release: 1%{?dist}
Summary: PHP Enum implementation
@@ -38,9 +38,10 @@ BuildRequires: php-reflection
BuildRequires: php-json
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^4.8.35|^5.7|^6.0",
+# "phpunit/phpunit": "^7",
# "squizlabs/php_codesniffer": "1.*"
-%global phpunit %{_bindir}/phpunit6
+# "vimeo/psalm": "^3.8"
+%global phpunit %{_bindir}/phpunit7
BuildRequires: %{phpunit}
# Required by autoloader
BuildRequires: php-composer(fedora/autoloader)
@@ -120,6 +121,10 @@ exit $ret
%changelog
+* Fri Feb 7 2020 Remi Collet <remi@remirepo.net> - 1.7.4-1
+- update to 1.7.4
+- switch to phpunit7
+
* Tue Aug 20 2019 Remi Collet <remi@remirepo.net> - 1.7.2-1
- update to 1.7.2