summaryrefslogtreecommitdiffstats
path: root/php-myclabs-deep-copy.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-myclabs-deep-copy.spec')
-rw-r--r--php-myclabs-deep-copy.spec45
1 files changed, 26 insertions, 19 deletions
diff --git a/php-myclabs-deep-copy.spec b/php-myclabs-deep-copy.spec
index 10adb72..7374492 100644
--- a/php-myclabs-deep-copy.spec
+++ b/php-myclabs-deep-copy.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-myclabs-deep-copy
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 776f831124e9c62e1a2c601ecc52e776d8bb7220
+%global gh_commit 14daed4296fae74d9e3201d2c4925d1acb7aa614
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner myclabs
%global gh_project DeepCopy
@@ -16,7 +16,7 @@
%bcond_without tests
Name: php-myclabs-deep-copy%{major}
-Version: 1.10.2
+Version: 1.11.0
Release: 1%{?dist}
Summary: Create deep copies (clones) of your objects
@@ -35,21 +35,19 @@ BuildRequires: php(language) >= 7.1
BuildRequires: php-reflection
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "doctrine/collections": "^1.0",
-# "doctrine/common": "^2.6",
-# "phpunit/phpunit": "^7.1"
+# "doctrine/collections": "^1.6.8",
+# "doctrine/common": "^2.13.3 || ^3.2.2",
+# "phpunit/phpunit": "^7.5.20 || ^8.5.23 || ^9.5.13"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(doctrine/collections) >= 1.0 with php-composer(doctrine/collections) < 2)
-BuildRequires: (php-composer(doctrine/common) >= 2.6 with php-composer(doctrine/common) < 3)
-# remirepo:6
+BuildRequires: (php-composer(doctrine/collections) >= 1.6.8 with php-composer(doctrine/collections) < 2)
+BuildRequires: (php-composer(doctrine/common) >= 3.2.2 with php-composer(doctrine/common) < 4)
+# remirepo:4
%else
-BuildRequires: php-doctrine-collections < 2
-BuildRequires: php-doctrine-collections >= 1.0
-BuildRequires: php-doctrine-common < 3
-BuildRequires: php-doctrine-common >= 2.6
+BuildRequires: php-doctrine-collections >= 1.6.8
+BuildRequires: php-doctrine-common3 >= 3.2.2
%endif
-BuildRequires: phpunit7 >= 7.1
+BuildRequires: phpunit9 >= 9.5.13
# Required by autoloader
BuildRequires: php-composer(fedora/autoloader)
%endif
@@ -99,15 +97,17 @@ cat << 'EOF' | tee vendor/autoload.php
require '%{buildroot}%{php_home}/%{gh_project}%{major}/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('DeepCopy\\', dirname(__DIR__).'/fixtures/');
\Fedora\Autoloader\Autoload::addPsr4('DeepCopyTest\\', dirname(__DIR__).'/tests/DeepCopyTest/');
-require_once '%{php_home}/Doctrine/Common/Collections/autoload.php';
-require_once '%{php_home}/Doctrine/Common/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Doctrine/Common/Collections/autoload.php',
+ '%{php_home}/Doctrine/Common3/autoload.php',
+]);
EOF
ret=0
-for cmd in php php72 php73 php74 php80; do
+for cmd in php php74 php80 php81; do
if which $cmd; then
- $cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{gh_project}%{major}/autoload.php \
- %{_bindir}/phpunit7 --verbose || ret=1
+ $cmd -d auto_prepend_file=vendor/autoload.php \
+ %{_bindir}/phpunit9 --verbose || ret=1
fi
done
exit $ret
@@ -126,6 +126,13 @@ exit $ret
%changelog
+* Thu Mar 3 2022 Remi Collet <remi@remirepo.net> - 1.11.0-1
+- update to 1.11.0
+
+* Thu Mar 3 2022 Remi Collet <remi@remirepo.net> - 1.10.3-1
+- update to 1.10.3
+- switch to phpunit9 and doctrine/common v3
+
* Sat Nov 14 2020 Remi Collet <remi@remirepo.net> - 1.10.2-1
- update to 1.10.2