summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-10-20 15:43:51 +0200
committerRemi Collet <remi@remirepo.net>2017-10-20 15:43:51 +0200
commitfb536d638ba1c51a3e5fbeba6e9e05b171e68435 (patch)
treed8d596a39a43372091b6d402be8d88e43f8248a9
parent1610ae0084fe8a801639cce584c7e76bb94baa5c (diff)
v1.7.0
-rw-r--r--composer.json26
-rw-r--r--php-myclabs-deep-copy-autoload.php1
-rw-r--r--php-myclabs-deep-copy.spec25
3 files changed, 38 insertions, 14 deletions
diff --git a/composer.json b/composer.json
index d20287a..d5d3a77 100644
--- a/composer.json
+++ b/composer.json
@@ -3,19 +3,33 @@
"type": "library",
"description": "Create deep copies (clones) of your objects",
"keywords": ["clone", "copy", "duplicate", "object", "object graph"],
- "homepage": "https://github.com/myclabs/DeepCopy",
"license": "MIT",
+
"autoload": {
- "psr-4": { "DeepCopy\\": "src/DeepCopy/" }
+ "psr-4": {
+ "DeepCopy\\": "src/DeepCopy/"
+ },
+ "files": [
+ "src/DeepCopy/deep_copy.php"
+ ]
},
"autoload-dev": {
- "psr-4": { "DeepCopyTest\\": "tests/DeepCopyTest/" }
+ "psr-4": {
+ "DeepCopy\\": "fixtures/",
+ "DeepCopyTest\\": "tests/DeepCopyTest/"
+ }
},
+
"require": {
- "php": ">=5.4.0"
+ "php": "^5.6 || ^7.0"
},
"require-dev": {
- "doctrine/collections": "1.*",
- "phpunit/phpunit": "~4.1"
+ "doctrine/collections": "^1.0",
+ "doctrine/common": "^2.6",
+ "phpunit/phpunit": "^4.1"
+ },
+
+ "config": {
+ "sort-packages": true
}
}
diff --git a/php-myclabs-deep-copy-autoload.php b/php-myclabs-deep-copy-autoload.php
index 57c6dfe..7392447 100644
--- a/php-myclabs-deep-copy-autoload.php
+++ b/php-myclabs-deep-copy-autoload.php
@@ -2,6 +2,7 @@
/* Autoloader for myclabs/deep-copy and its dependencies */
require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+require_once __DIR__ . '/deep_copy.php';
\Fedora\Autoloader\Autoload::addPsr4('DeepCopy\\', __DIR__);
diff --git a/php-myclabs-deep-copy.spec b/php-myclabs-deep-copy.spec
index f0894cd..cad1057 100644
--- a/php-myclabs-deep-copy.spec
+++ b/php-myclabs-deep-copy.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 8e6e04167378abf1ddb4d3522d8755c5fd90d102
+%global gh_commit 3b8a3a99ba1f6a3952ac2747d989303cbd6b7a3e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner myclabs
%global gh_project DeepCopy
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-myclabs-deep-copy
-Version: 1.6.1
+Version: 1.7.0
Release: 1%{?dist}
Summary: Create deep copies (clones) of your objects
@@ -30,21 +30,25 @@ Source2: %{name}-autoload.php
BuildArch: noarch
%if %{with_tests}
# For tests
-BuildRequires: php(language) >= 5.4
+BuildRequires: php(language) >= 5.6
BuildRequires: php-reflection
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "doctrine/collections": "1.*",
-# "phpunit/phpunit": "~4.1"
-BuildRequires: php-composer(doctrine/collections) >= 1
+# "doctrine/collections": "^1.0",
+# "doctrine/common": "^2.6",
+# "phpunit/phpunit": "^4.1"
+BuildRequires: php-composer(doctrine/collections) < 2
+BuildRequires: php-composer(doctrine/collections) >= 1.0
+BuildRequires: php-composer(doctrine/common) < 3
+BuildRequires: php-composer(doctrine/common) >= 2.6
BuildRequires: php-composer(phpunit/phpunit) >= 4.1
# Required by autoloader
BuildRequires: php-composer(fedora/autoloader)
%endif
# From composer.json, "require": {
-# "php": ">=5.4.0"
-Requires: php(language) >= 5.4
+# "php": "^5.6 || ^7.0"
+Requires: php(language) >= 5.6
# From phpcompatinfo report for version 1.3.0
Requires: php-reflection
Requires: php-spl
@@ -81,8 +85,10 @@ mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
require '%{buildroot}%{php_home}/%{gh_project}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('DeepCopy\\', dirname(__DIR__).'/fixtures/');
\Fedora\Autoloader\Autoload::addPsr4('DeepCopyTest\\', dirname(__DIR__).'/tests/DeepCopyTest/');
require_once '%{php_home}/Doctrine/Common/Collections/autoload.php';
+require_once '%{php_home}/Doctrine/Common/autoload.php';
EOF
ret=0
@@ -107,6 +113,9 @@ exit $ret
%changelog
+* Fri Oct 20 2017 Remi Collet <remi@remirepo.net> - 1.7.0-1
+- Update to 1.7.0
+- raise dependency on PHP 5.6
* Thu Apr 13 2017 Remi Collet <remi@remirepo.net> - 1.6.1-1
- Update to 1.6.1