summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-11-12 10:18:37 +0100
committerRemi Collet <remi@php.net>2024-11-12 10:18:37 +0100
commitdb23f48b5617e0df68608768f48ab00af1d206ef (patch)
tree018a68827bf9038406fefdbe496ce38914ae9176
parent100a5f034e1ab11132f58856f9719cad3e2cf038 (diff)
update to 1.12.1HEADmaster
-rw-r--r--php-myclabs-deep-copy.spec41
1 files changed, 14 insertions, 27 deletions
diff --git a/php-myclabs-deep-copy.spec b/php-myclabs-deep-copy.spec
index f1a8524..77a8d9f 100644
--- a/php-myclabs-deep-copy.spec
+++ b/php-myclabs-deep-copy.spec
@@ -6,14 +6,9 @@
#
# Please, preserve the changelog entries
#
-%if 0%{?fedora} >= 40 || 0%{?rhel} >= 10
-# Disabled as missing doctrine packages
-%bcond_with tests
-%else
%bcond_without tests
-%endif
-%global gh_commit 3a6b9a42cd8f8771bd4295d13e1423fa7f3d942c
+%global gh_commit 123267b2c49fbf30d78a7b2d333f6be754b94845
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner myclabs
%global gh_project DeepCopy
@@ -22,8 +17,8 @@
%global php_home %{_datadir}/php
Name: php-myclabs-deep-copy%{major}
-Version: 1.12.0
-Release: 2%{?dist}
+Version: 1.12.1
+Release: 1%{?dist}
Summary: Create deep copies (clones) of your objects
@@ -44,17 +39,7 @@ BuildRequires: php-spl
# "doctrine/common": "^2.13.3 || ^3.2.2",
# "phpspec/prophecy": "^1.10",
# "phpunit/phpunit": "^7.5.20 || ^8.5.23 || ^9.5.13"
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(doctrine/collections) >= 1.6.8 with php-composer(doctrine/collections) < 2)
-BuildRequires: (php-composer(doctrine/common) >= 3.2.2 with php-composer(doctrine/common) < 4)
BuildRequires: (php-composer(phpspec/prophecy) >= 1.10 with php-composer(phpspec/prophecy) < 2)
-# remirepo:5
-%else
-BuildRequires: php-doctrine-collections >= 1.6.8
-BuildRequires: php-doctrine-common3 >= 3.2.2
-BuildRequires: php-phpspec-prophecy >= 1.10
-%endif
BuildRequires: phpunit9 >= 9.5.13
%endif
# For autoloader
@@ -69,9 +54,6 @@ Requires: php-date
Requires: php-spl
# Required by autoloader
Requires: php-composer(fedora/autoloader)
-# remirepo:2
-Obsoletes: php-myclabs-deep-copy19 < 1.10
-Provides: php-myclabs-deep-copy19 = %{version}
Provides: php-composer(%{gh_owner}/%{c_project}) = %{version}
@@ -107,17 +89,21 @@ require '%{buildroot}%{php_home}/%{gh_project}%{major}/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('DeepCopy\\', dirname(__DIR__).'/fixtures/');
\Fedora\Autoloader\Autoload::addPsr4('DeepCopyTest\\', dirname(__DIR__).'/tests/DeepCopyTest/');
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/Doctrine/Common/Collections/autoload.php',
- '%{php_home}/Doctrine/Common3/autoload.php',
'%{php_home}/Prophecy/autoload.php',
]);
EOF
+# disable doctrine related tests
+rm -r tests/DeepCopyTest/Matcher/Doctrine \
+ tests/DeepCopyTest/Filter/Doctrine
+
ret=0
-for cmd in php php81 php82 php83; do
+for cmd in php php81 php82 php83 php84; do
if which $cmd; then
$cmd -d auto_prepend_file=vendor/autoload.php \
- %{_bindir}/phpunit9 --verbose || ret=1
+ %{_bindir}/phpunit9 \
+ --filter '^((?!(test_it_can_apply_two_filters_with_chainable_filter|test_it_can_copy_property_after_applying_doctrine_proxy_filter_with_chainable_filter)).)*$' \
+ --verbose || ret=1
fi
done
exit $ret
@@ -127,8 +113,6 @@ exit $ret
%files
-# remirepo:1
-%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
%doc README.md
@@ -136,6 +120,9 @@ exit $ret
%changelog
+* Tue Nov 12 2024 Remi Collet <remi@remirepo.net> - 1.12.1-1
+- update to 1.12.1
+
* Thu Jun 13 2024 Remi Collet <remi@remirepo.net> - 1.12.0-2
- update to 1.12.0
- disable test suite