summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-10-05 18:40:12 +0200
committerRemi Collet <fedora@famillecollet.com>2015-10-05 18:40:12 +0200
commitad6c9ed41cebcf446c43eb58a92a12b98ce9dc5e (patch)
tree735d426e1390f0b558ad0c7e4d185a7c4914052a
parent61bb23d1d43f27f626cd3178700a7753c5261c1c (diff)
php-myclabs-deep-copy: 1.4.0
-rwxr-xr-xmakesrc.sh1
-rw-r--r--php-myclabs-deep-copy.spec16
2 files changed, 11 insertions, 6 deletions
diff --git a/makesrc.sh b/makesrc.sh
index 05a6054..bde65fc 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -15,6 +15,7 @@ git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
echo "Getting commit..."
pushd $PROJECT-$COMMIT
git checkout $COMMIT
+cp composer.json ../composer-$VERSION.json
popd
echo "Archiving..."
diff --git a/php-myclabs-deep-copy.spec b/php-myclabs-deep-copy.spec
index b35a1b2..eeda4f1 100644
--- a/php-myclabs-deep-copy.spec
+++ b/php-myclabs-deep-copy.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 95d662954e06000cdf63ec9c9f0a6c598d9c5eb9
+%global gh_commit d8093b631a31628342d0703764935f8bac2c56b1
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner myclabs
%global gh_project DeepCopy
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-myclabs-deep-copy
-Version: 1.3.1
+Version: 1.4.0
Release: 1%{?dist}
Summary: Create deep copies (clones) of your objects
@@ -77,13 +77,14 @@ cp -pr src/%{gh_project} %{buildroot}%{php_home}/%{gh_project}
%check
%if %{with_tests}
mkdir vendor
-cat <<EOF | tee vendor/autoload.php
+cat << 'EOF' | tee vendor/autoload.php
<?php
-require_once '%{buildroot}%{php_home}/%{gh_project}/autoload.php';
-\$fedoraClassLoader->addPrefix('DeepCopyTest\\\\', __DIR__ . '/../tests');
-\$fedoraClassLoader->addPrefix('Doctrine\\\\', '%{php_home}');
+require '%{buildroot}%{php_home}/%{gh_project}/autoload.php';
+$fedoraClassLoader->addPrefix('DeepCopyTest\\', __DIR__ . '/../tests');
+$fedoraClassLoader->addPrefix('Doctrine\\', '%{php_home}');
EOF
+%{_bindir}/php -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
%{_bindir}/phpunit --verbose
%else
: Test suite disabled
@@ -104,6 +105,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Oct 5 2015 Remi Collet <remi@fedoraproject.org> - 1.4.0-1
+- update to 1.4.0
+
* Mon Jul 20 2015 Remi Collet <remi@fedoraproject.org> - 1.3.1-1
- update to 1.3.1 (no change, pr #14 merged)