summaryrefslogtreecommitdiffstats
path: root/php-mockery.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-mockery.spec')
-rw-r--r--php-mockery.spec15
1 files changed, 8 insertions, 7 deletions
diff --git a/php-mockery.spec b/php-mockery.spec
index 72cc922..8ee6e4d 100644
--- a/php-mockery.spec
+++ b/php-mockery.spec
@@ -9,7 +9,7 @@
#
%bcond_without tests
-%global gh_commit b8e0bb7d8c604046539c1115994632c74dcb361e
+%global gh_commit 0cc058854b3195ba21dc6b1f7b1f60f4ef3a9c06
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner mockery
%global gh_project mockery
@@ -17,7 +17,7 @@
%global major 1
Name: php-mockery
-Version: 1.6.6
+Version: 1.6.7
Release: 1%{?dist}
Summary: Mockery is a simple but flexible PHP mock object framework
@@ -33,10 +33,8 @@ BuildArch: noarch
%if %{with tests}
BuildRequires: php(language) >= 7.3
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^8.5|^9.6.10",
-# "psalm/plugin-phpunit": "^0.18.4",
-# "symplify/easy-coding-standard": "^11.5.0",
-# "vimeo/psalm": "^4.30"
+# "phpunit/phpunit": "^8.5 || ^9.6.10",
+# "symplify/easy-coding-standard": "^12.0.8"
%global phpunit %{_bindir}/phpunit9
BuildRequires: phpunit9 >= 9.6.10
# remirepo:1
@@ -122,7 +120,7 @@ ret=0
# need investigation
rm tests/Mockery/MockeryCanMockClassesWithSemiReservedWordsTest.php
-for cmd in php php80 php81 php82 php83; do
+for cmd in php php81 php82 php83; do
if which $cmd; then
$cmd %{_bindir}/phpunit9 \
--no-coverage \
@@ -143,6 +141,9 @@ exit $ret
%changelog
+* Mon Dec 11 2023 Remi Collet <remi@remirepo.net> - 1.6.7-1
+- update to 1.6.7
+
* Thu Aug 24 2023 Remi Collet <remi@remirepo.net> - 1.6.6-1
- update to 1.6.6