summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json5
-rw-r--r--php-mockery.spec13
2 files changed, 12 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index 42a077b..44ffe51 100644
--- a/composer.json
+++ b/composer.json
@@ -36,7 +36,7 @@
"hamcrest/hamcrest-php": "^2.0.1"
},
"require-dev": {
- "phpunit/phpunit": "~5.7.10|~6.5|~7.0|~8.0|~9.0"
+ "phpunit/phpunit": "^5.7.10|^6.5|^7.5|^8.5|^9.3"
},
"autoload": {
"psr-0": {
@@ -48,6 +48,9 @@
"test\\": "tests/"
}
},
+ "config": {
+ "preferred-install": "dist"
+ },
"extra": {
"branch-alias": {
"dev-master": "1.3.x-dev"
diff --git a/php-mockery.spec b/php-mockery.spec
index f7789f2..0579ca0 100644
--- a/php-mockery.spec
+++ b/php-mockery.spec
@@ -7,7 +7,7 @@
#
# Please preserve changelog entries
#
-%global gh_commit 9b6f117dd7d36dc3858d8d8ddf9b3d584fcae283
+%global gh_commit 60fa2f67f6e4d3634bb4a45ff3171fa52215800d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner mockery
%global gh_project mockery
@@ -16,7 +16,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-mockery
-Version: 1.3.2
+Version: 1.3.3
Release: 1%{?dist}
Summary: Mockery is a simple but flexible PHP mock object framework
@@ -32,16 +32,16 @@ BuildArch: noarch
%if %{with_tests}
BuildRequires: php(language) >= 5.6.0
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "~5.7.10|~6.5|~7.0|~8.0|~9.0"
+# "phpunit/phpunit": "^5.7.10|^6.5|^7.5|^8.5|^9.3"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9
+BuildRequires: phpunit9 >= 9.3
BuildRequires: (php-composer(hamcrest/hamcrest-php) >= 2.0.1 with php-composer(hamcrest/hamcrest-php) < 3)
# remirepo:5
%else
%global phpunit %{_bindir}/phpunit8
-BuildRequires: phpunit8
+BuildRequires: phpunit8 >= 8.5
BuildRequires: php-hamcrest2 >= 2.0.1
%endif
# Autoloader
@@ -141,6 +141,9 @@ exit $ret
%changelog
+* Mon Aug 17 2020 Remi Collet <remi@remirepo.net> - 1.3.3-1
+- update to 1.3.3
+
* Tue Jul 21 2020 Remi Collet <remi@remirepo.net> - 1.3.2-1
- update to 1.3.2
- switch to phpunit9