summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json4
-rw-r--r--php-mockery.spec34
2 files changed, 22 insertions, 16 deletions
diff --git a/composer.json b/composer.json
index bf0bd0e..42a077b 100644
--- a/composer.json
+++ b/composer.json
@@ -33,10 +33,10 @@
"require": {
"php": ">=5.6.0",
"lib-pcre": ">=7.0",
- "hamcrest/hamcrest-php": "~2.0"
+ "hamcrest/hamcrest-php": "^2.0.1"
},
"require-dev": {
- "phpunit/phpunit": "~5.7.10|~6.5|~7.0|~8.0"
+ "phpunit/phpunit": "~5.7.10|~6.5|~7.0|~8.0|~9.0"
},
"autoload": {
"psr-0": {
diff --git a/php-mockery.spec b/php-mockery.spec
index cb9c1af..1d9021f 100644
--- a/php-mockery.spec
+++ b/php-mockery.spec
@@ -7,7 +7,7 @@
#
# Please preserve changelog entries
#
-%global gh_commit f69bbde7d7a75d6b2862d9ca8fab1cd28014b4be
+%global gh_commit 9b6f117dd7d36dc3858d8d8ddf9b3d584fcae283
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner mockery
%global gh_project mockery
@@ -16,13 +16,14 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-mockery
-Version: 1.3.1
+Version: 1.3.2
Release: 1%{?dist}
Summary: Mockery is a simple but flexible PHP mock object framework
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
# Use our autoloader
Patch0: %{gh_project}-tests.patch
@@ -31,17 +32,17 @@ BuildArch: noarch
%if %{with_tests}
BuildRequires: php(language) >= 5.6.0
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "~5.7.10|~6.5|~7.0|~8.0"
+# "phpunit/phpunit": "~5.7.10|~6.5|~7.0|~8.0|~9.0"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-%global phpunit %{_bindir}/phpunit8
-BuildRequires: phpunit8
-BuildRequires: (php-composer(hamcrest/hamcrest-php) >= 2.0 with php-composer(hamcrest/hamcrest-php) < 3)
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9
+BuildRequires: (php-composer(hamcrest/hamcrest-php) >= 2.0.1 with php-composer(hamcrest/hamcrest-php) < 3)
# remirepo:5
%else
-%global phpunit %{_bindir}/phpunit
-BuildRequires: php-phpunit-PHPUnit >= 5.7.10
-BuildRequires: php-hamcrest2
+%global phpunit %{_bindir}/phpunit8
+BuildRequires: phpunit8
+BuildRequires: php-hamcrest2 >= 2.0.1
%endif
# Autoloader
%endif
@@ -54,10 +55,10 @@ BuildRequires: php-fedora-autoloader-devel
Requires: php(language) >= 5.6.0
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(hamcrest/hamcrest-php) >= 2.0 with php-composer(hamcrest/hamcrest-php) < 3)
+Requires: (php-composer(hamcrest/hamcrest-php) >= 2.0.1 with php-composer(hamcrest/hamcrest-php) < 3)
# remirepo:3
%else
-Requires: php-hamcrest2
+Requires: php-hamcrest2 >= 2.0.1
%endif
# From phpcompatinfo report for version 1.0
Requires: php-pcre
@@ -113,7 +114,7 @@ phpab --output tests/classmap.php --exclude */SemiReservedWordsAsMethods.php tes
: Run upstream test suite
ret=0
-for cmd in "php %{phpunit}" "php71 %{_bindir}/phpunit7" php72 php73 php74; do
+for cmd in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
if which $cmd; then
set $cmd
# see .travis.yml
@@ -121,7 +122,7 @@ for cmd in "php %{phpunit}" "php71 %{_bindir}/phpunit7" php72 php73 php74; do
then SUITE="Mockery Test Suite PHP56"
else SUITE="Mockery Test Suite"
fi
- $1 ${2:-%{_bindir}/phpunit8} \
+ $1 ${2:-%{_bindir}/phpunit9} \
--no-coverage \
--verbose --testsuite="$SUITE" || ret=1
fi
@@ -140,6 +141,11 @@ exit $ret
%changelog
+* Tue Jul 21 2020 Remi Collet <remi@remirepo.net> - 1.3.2-1
+- update to 1.3.2
+- switch to phpunit9
+- raise dependency on hamcrest/hamcrest-php 2.0.1
+
* Fri Jan 3 2020 Remi Collet <remi@remirepo.net> - 1.3.1-1
- update to 1.3.1