summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-08-24 15:42:08 +0200
committerRemi Collet <remi@php.net>2023-08-24 15:42:08 +0200
commitf8540c0186a782011b88d486c4d2e18bf07f616e (patch)
tree27eff014b08b53d09da0cbffdb11837b1890ded0
parent1dabe6fe9d0a4030ea91e28cc02ca6383a103084 (diff)
update to 1.6.6
-rw-r--r--composer.json10
-rw-r--r--php-mockery.spec19
2 files changed, 17 insertions, 12 deletions
diff --git a/composer.json b/composer.json
index 66b9572..68c1a44 100644
--- a/composer.json
+++ b/composer.json
@@ -44,15 +44,15 @@
"security": "https://github.com/mockery/mockery/security/advisories"
},
"require": {
- "php": ">=7.4,<8.3",
+ "php": ">=7.3",
"lib-pcre": ">=7.0",
"hamcrest/hamcrest-php": "^2.0.1"
},
"require-dev": {
- "phpunit/phpunit": "^8.5 || ^9.3",
+ "phpunit/phpunit": "^8.5 || ^9.6.10",
"psalm/plugin-phpunit": "^0.18.4",
"symplify/easy-coding-standard": "^11.5.0",
- "vimeo/psalm": "^5.13.1"
+ "vimeo/psalm": "^4.30"
},
"conflict": {
"phpunit/phpunit": "<8.0"
@@ -69,16 +69,18 @@
"autoload-dev": {
"psr-4": {
"Fixture\\": "tests/Fixture/",
+ "Mockery\\Tests\\Unit\\": "tests/Unit",
"test\\": "tests/"
},
"files": [
+ "fixtures/autoload.php",
"vendor/hamcrest/hamcrest-php/hamcrest/Hamcrest.php"
]
},
"config": {
"optimize-autoloader": true,
"platform": {
- "php": "7.4.999"
+ "php": "7.3.999"
},
"preferred-install": "dist",
"sort-packages": true
diff --git a/php-mockery.spec b/php-mockery.spec
index c1b6e28..72cc922 100644
--- a/php-mockery.spec
+++ b/php-mockery.spec
@@ -9,7 +9,7 @@
#
%bcond_without tests
-%global gh_commit d1413755e26fe56a63455f7753221c86cbb88f66
+%global gh_commit b8e0bb7d8c604046539c1115994632c74dcb361e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner mockery
%global gh_project mockery
@@ -17,7 +17,7 @@
%global major 1
Name: php-mockery
-Version: 1.6.4
+Version: 1.6.6
Release: 1%{?dist}
Summary: Mockery is a simple but flexible PHP mock object framework
@@ -31,14 +31,14 @@ Patch0: %{gh_project}-tests.patch
BuildArch: noarch
%if %{with tests}
-BuildRequires: php(language) >= 7.4
+BuildRequires: php(language) >= 7.3
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^8.5|^9.3",
+# "phpunit/phpunit": "^8.5|^9.6.10",
# "psalm/plugin-phpunit": "^0.18.4",
# "symplify/easy-coding-standard": "^11.5.0",
-# "vimeo/psalm": "^5.13.1"
+# "vimeo/psalm": "^4.30"
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.3
+BuildRequires: phpunit9 >= 9.6.10
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(hamcrest/hamcrest-php) >= 2.0.1 with php-composer(hamcrest/hamcrest-php) < 3)
@@ -52,7 +52,7 @@ BuildRequires: php-pdo
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": ">=7.4,<8.3",
+# "php": ">=7.3",
# "lib-pcre": ">=7.0",
# "hamcrest/hamcrest-php": "~2.0"
Requires: php(language) >= 7.3
@@ -122,7 +122,7 @@ ret=0
# need investigation
rm tests/Mockery/MockeryCanMockClassesWithSemiReservedWordsTest.php
-for cmd in php php80 php81 php82; do
+for cmd in php php80 php81 php82 php83; do
if which $cmd; then
$cmd %{_bindir}/phpunit9 \
--no-coverage \
@@ -143,6 +143,9 @@ exit $ret
%changelog
+* Thu Aug 24 2023 Remi Collet <remi@remirepo.net> - 1.6.6-1
+- update to 1.6.6
+
* Thu Jul 20 2023 Remi Collet <remi@remirepo.net> - 1.6.4-1
- update to 1.6.4