summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-06-13 09:11:37 +0200
committerRemi Collet <remi@php.net>2023-06-13 09:11:37 +0200
commit177f9f52d6d53e394c09e85aa731ed451c2ab595 (patch)
tree50a6ee2482205221f338e77214b065fb0cf389d4
parentb52a75823634b606334bc104deb09054bdba91eb (diff)
update to 2.4.1 (no change)
-rw-r--r--composer.json2
-rw-r--r--php-mock2.spec11
2 files changed, 8 insertions, 5 deletions
diff --git a/composer.json b/composer.json
index 30f3806..fd01774 100644
--- a/composer.json
+++ b/composer.json
@@ -2,7 +2,7 @@
"name": "php-mock/php-mock",
"type": "library",
"description": "PHP-Mock can mock built-in PHP functions (e.g. time()). PHP-Mock relies on PHP's namespace fallback policy. No further extension is needed.",
- "keywords": ["mock", "stub", "test double", "function", "test", "TDD", "BDD"],
+ "keywords": ["mock", "stub", "test double", "function", "test", "testing", "TDD", "BDD"],
"homepage": "https://github.com/php-mock/php-mock",
"license": "WTFPL",
"authors": [
diff --git a/php-mock2.spec b/php-mock2.spec
index 4691d74..53c7490 100644
--- a/php-mock2.spec
+++ b/php-mock2.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 6f71999665d27fbdf684c1639981e96eff540b5f
+%global gh_commit 6240b6f0a76d7b9d1ee4d70e686a7cc711619a9d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner php-mock
%global gh_project php-mock
@@ -14,7 +14,7 @@
%global major 2
Name: php-mock%{major}
-Version: 2.4.0
+Version: 2.4.1
Release: 1%{?dist}
Summary: PHP-Mock can mock built-in PHP functions
@@ -134,7 +134,7 @@ if [ -x %{_bindir}/phpunit8 ]; then
fi
if [ -x %{_bindir}/phpunit9 ]; then
- for cmd in php php80 php81 php82;do
+ for cmd in php php80 php81 php82 php83;do
if which $cmd; then
$cmd %{_bindir}/phpunit9 \
--filter '^((?!(testDefiningAfterCallingUnqualified|testEnable)).)*$' \
@@ -144,7 +144,7 @@ if [ -x %{_bindir}/phpunit9 ]; then
fi
if [ -x %{_bindir}/phpunit10 ]; then
- for cmd in php php81 php82;do
+ for cmd in php php81 php82 php83;do
if which $cmd; then
$cmd %{_bindir}/phpunit10 \
--filter '^((?!(testDefiningAfterCallingUnqualified|testEnable)).)*$' \
@@ -169,6 +169,9 @@ exit $ret
%changelog
+* Tue Jun 13 2023 Remi Collet <remi@remirepo.net> - 2.4.1-1
+- update to 2.4.1 (no change)
+
* Mon Feb 13 2023 Remi Collet <remi@remirepo.net> - 2.4.0-1
- update to 2.4.0
- allow phpunit10