summaryrefslogtreecommitdiffstats
path: root/php-mock-phpunit2.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-10-08 07:23:15 +0200
committerRemi Collet <remi@remirepo.net>2018-10-08 07:23:15 +0200
commit772569f15e192a07a230b38be1700c1ac5c28cc8 (patch)
treeb403bed0a454681cf336e6470838a584d0e430dd /php-mock-phpunit2.spec
parent07db65f4a074df1b508fda3751a3b5deb4cdb96d (diff)
v2.1.2
Diffstat (limited to 'php-mock-phpunit2.spec')
-rw-r--r--php-mock-phpunit2.spec16
1 files changed, 10 insertions, 6 deletions
diff --git a/php-mock-phpunit2.spec b/php-mock-phpunit2.spec
index f976f96..d0ee562 100644
--- a/php-mock-phpunit2.spec
+++ b/php-mock-phpunit2.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit ff1cc1d4e7478ce74221e05742588619bee84f69
+%global gh_commit 57b92e621f14c2c07a4567cd29ed4e87de0d2912
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner php-mock
%global gh_project php-mock-phpunit
@@ -14,7 +14,7 @@
%global major 2
Name: php-mock-phpunit%{major}
-Version: 2.1.1
+Version: 2.1.2
Release: 1%{?dist}
Summary: Mock built-in PHP functions with PHPUnit.
@@ -97,6 +97,7 @@ cp -pr compatibility %{buildroot}%{_datadir}/php/phpmock%{major}/phpunit/compati
cp -p autoload.php %{buildroot}%{_datadir}/php/phpmock%{major}/phpunit/compatibility.php
cp -p rpm.php %{buildroot}%{_datadir}/php/phpmock%{major}/phpunit/autoload.php
+
%check
%if %{with_tests}
mkdir vendor
@@ -108,20 +109,20 @@ EOF
ret=0
: Run upstream test suite with phpunit6
-for cmd in php php70 php71 php72; do
+for cmd in php php70 php71 php72 php73; do
if which $cmd; then
$cmd %{_bindir}/phpunit6 --verbose || ret=1
fi
done
-%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
+if [ -x %{_bindir}/phpunit7 ]; then
: Run upstream test suite with phpunit7
-for cmd in php php71 php72; do
+for cmd in php php71 php72 php73; do
if which $cmd; then
$cmd %{_bindir}/phpunit7 --verbose || ret=1
fi
done
-%endif
+fi
exit $ret
%else
: bootstrap build with test suite disabled
@@ -137,6 +138,9 @@ exit $ret
%changelog
+* Mon Oct 8 2018 Remi Collet <remi@remirepo.net> - 2.1.2-1
+- update to 2.1.2
+
* Mon Apr 9 2018 Remi Collet <remi@remirepo.net> - 2.1.1-1
- update to 2.1.1