summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-03-23 11:53:44 +0100
committerRemi Collet <remi@remirepo.net>2021-03-23 11:53:44 +0100
commit64b9912b7e1eb1aedccde4fdd924466e2c50327d (patch)
tree7b5e7a691453ea891197995cc9ce5cbcee739f4d
parentdced18b7d3f20d4ee60637da6102a52fb73baf2f (diff)
drop dependency on phpunit6
-rw-r--r--php-mock-phpunit2.spec29
1 files changed, 17 insertions, 12 deletions
diff --git a/php-mock-phpunit2.spec b/php-mock-phpunit2.spec
index 771c77b..9bf82f8 100644
--- a/php-mock-phpunit2.spec
+++ b/php-mock-phpunit2.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-mock-phpunit2
#
-# Copyright (c) 2016-2020 Remi Collet
+# Copyright (c) 2016-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -15,7 +15,7 @@
Name: php-mock-phpunit%{major}
Version: 2.6.0
-Release: 1%{?dist}
+Release: 4%{?dist}
Summary: Mock built-in PHP functions with PHPUnit.
License: WTFPL
@@ -34,14 +34,15 @@ BuildRequires: (php-composer(php-mock/php-mock) >= 2.2 with php-co
BuildRequires: php-mock-integration2 >= 2.1
BuildRequires: php-mock2 >= 2.2
%endif
-BuildRequires: phpunit6
%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8
-BuildRequires: phpunit7
BuildRequires: phpunit8
%endif
-# remirepo:3
+# remirepo:6
%if 0%{?fedora} >= 31 || 0%{?rhel} >= 8
BuildRequires: phpunit9
+%else
+BuildRequires: phpunit6
+BuildRequires: phpunit7
%endif
# For autoloader
BuildRequires: php-composer(fedora/autoloader)
@@ -56,12 +57,11 @@ BuildRequires: php-composer(fedora/autoloader)
Requires: php(language) >= 7
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (phpunit6 or phpunit7 or phpunit8 or phpunit9)
+Requires: (phpunit8 or phpunit9)
Requires: (php-composer(php-mock/php-mock-integration) >= 2.1 with php-composer(php-mock/php-mock-integration) < 3)
Requires: (php-composer(php-mock/php-mock) >= 2.2 with php-composer(php-mock/php-mock) < 3)
-# remirepo:5
+# remirepo:4
%else
-Requires: phpunit6
Requires: php-mock-integration2 >= 2.1
Requires: php-mock2 >= 2.2
%endif
@@ -118,15 +118,17 @@ EOF
ret=0
: Run upstream test suite with phpunit6
-for cmd in php php71 php72 php73; do
+if [ -x %{_bindir}/phpunit6 ]; then
+for cmd in php php72 php73; do
if which $cmd; then
$cmd %{_bindir}/phpunit6 --verbose || ret=1
fi
done
+fi
if [ -x %{_bindir}/phpunit7 ]; then
: Run upstream test suite with phpunit7
-for cmd in php php71 php72 php73 php74; do
+for cmd in php php73 php74; do
if which $cmd; then
$cmd %{_bindir}/phpunit7 --verbose || ret=1
fi
@@ -135,7 +137,7 @@ fi
if [ -x %{_bindir}/phpunit8 ]; then
: Run upstream test suite with phpunit8
-for cmd in php php72 php73 php74; do
+for cmd in php php73 php74 php80; do
if which $cmd; then
$cmd %{_bindir}/phpunit8 --verbose || ret=1
fi
@@ -144,7 +146,7 @@ fi
if [ -x %{_bindir}/phpunit9 ]; then
: Run upstream test suite with phpunit9
-for cmd in php php73 php74; do
+for cmd in php php73 php74 php80; do
if which $cmd; then
$cmd %{_bindir}/phpunit9 --verbose || ret=1
fi
@@ -166,6 +168,9 @@ exit $ret
%changelog
+* Tue Mar 23 2021 Remi Collet <remi@remirepo.net> - 2.6.0-4
+- drop dependency on phpunit6
+
* Mon Feb 10 2020 Remi Collet <remi@remirepo.net> - 2.6.0-1
- update to 2.6.0
- raise dependency on php-mock2 2.2