summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-03-21 09:53:43 +0100
committerRemi Collet <remi@php.net>2023-03-21 09:53:43 +0100
commit468cc5e6c0f248ad672dbfbbc085b569fb5b73ba (patch)
treef05071114f563b15d752bf8e3616c333b4424937
parent7184fb4bbd3eac59da4b3ffddf867e9af04c591e (diff)
update to 2.7.1
-rw-r--r--composer.json2
-rw-r--r--php-mock-phpunit2.spec13
2 files changed, 9 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index 3683e25..8b8e15f 100644
--- a/composer.json
+++ b/composer.json
@@ -19,7 +19,7 @@
},
"require": {
"php": ">=7",
- "phpunit/phpunit": "^6 || ^7 || ^8 || ^9 || ^10",
+ "phpunit/phpunit": "^6 || ^7 || ^8 || ^9 || ^10.0.17",
"php-mock/php-mock-integration": "^2.2.1"
},
"require-dev": {
diff --git a/php-mock-phpunit2.spec b/php-mock-phpunit2.spec
index b2df105..55e2440 100644
--- a/php-mock-phpunit2.spec
+++ b/php-mock-phpunit2.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 97b3278e65863e53066f31adb85d92334c0ea07b
+%global gh_commit dc4cf8896bf47647080dc5709a2c67ee9d437c21
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner php-mock
%global gh_project php-mock-phpunit
@@ -14,7 +14,7 @@
%global major 2
Name: php-mock-phpunit%{major}
-Version: 2.7.0
+Version: 2.7.1
Release: 1%{?dist}
Summary: Mock built-in PHP functions with PHPUnit.
@@ -42,8 +42,8 @@ BuildRequires: phpunit8
BuildRequires: phpunit9
# remirepo:6
# phpunit10 waiting for review
-%if 0%{?fedora} >= 38 || 0%{?rhel} >= 10
-BuildRequires: phpunit10
+%if 0%{?fedora} >= 37 || 0%{?rhel} >= 10
+BuildRequires: phpunit10 >= 10.0.17
%else
BuildRequires: phpunit7
%endif
@@ -53,7 +53,7 @@ BuildRequires: php-composer(fedora/autoloader)
# from composer.json, "require": {
# "php": ">=7",
-# "phpunit/phpunit": "^6 || ^7 || ^8 || ^9 || ^10",
+# "phpunit/phpunit": "^6 || ^7 || ^8 || ^9 || ^10.0.17",
# "php-mock/php-mock-integration": "^2.2.1"
# "conflict": {
# "phpunit/phpunit-mock-objects": "3.2.0"
@@ -173,6 +173,9 @@ exit $ret
%changelog
+* Tue Mar 21 2023 Remi Collet <remi@remirepo.net> - 2.7.1-1
+- update to 2.7.1
+
* Tue Mar 7 2023 Remi Collet <remi@remirepo.net> - 2.7.0-1
- update to 2.7.0
- raise dependency on php-mock-integration2 2.2.1