summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-04-08 10:46:48 +0200
committerRemi Collet <remi@remirepo.net>2019-04-08 10:46:48 +0200
commit2b41e9c11b059454aecc6d0f12bbff8ee2b8e1cd (patch)
tree2f7429dc5a31d1378781018fbfb7233462284ce0
parent9705a67e011a95bd96492b9a5a32cbf5b45906d7 (diff)
update to 2.3.0
raise dependency on php-mock2 2.1.1
-rw-r--r--php-mock-phpunit2.spec26
1 files changed, 16 insertions, 10 deletions
diff --git a/php-mock-phpunit2.spec b/php-mock-phpunit2.spec
index 4dca78a..969172b 100644
--- a/php-mock-phpunit2.spec
+++ b/php-mock-phpunit2.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit c3cee2c13cd3e7ae78655ec828fdef409f78e292
+%global gh_commit d49b8c5c6e5e0119b98c250012a68ecb0fac65ab
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner php-mock
%global gh_project php-mock-phpunit
@@ -14,8 +14,8 @@
%global major 2
Name: php-mock-phpunit%{major}
-Version: 2.2.0
-Release: 2%{?dist}
+Version: 2.3.0
+Release: 1%{?dist}
Summary: Mock built-in PHP functions with PHPUnit.
License: WTFPL
@@ -27,11 +27,12 @@ BuildRequires: php(language) >= 7
%if %{with_tests}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(php-mock/php-mock-integration) >= 2 with php-composer(php-mock/php-mock-integration) < 3)
-BuildRequires: (php-composer(php-mock/php-mock) >= 2.1 with php-composer(php-mock/php-mock) < 3)
-# remirepo:3
+BuildRequires: (php-composer(php-mock/php-mock-integration) >= 2 with php-composer(php-mock/php-mock-integration) < 3)
+BuildRequires: (php-composer(php-mock/php-mock) >= 2.1.1 with php-composer(php-mock/php-mock) < 3)
+# remirepo:4
%else
BuildRequires: php-mock-integration2
+BuildRequires: php-mock2 >= 2.1.1
%endif
BuildRequires: phpunit6
%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
@@ -54,12 +55,13 @@ Requires: php(language) >= 7
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (phpunit6 or phpunit7 or phpunit8)
-Requires: (php-composer(php-mock/php-mock-integration) >= 2 with php-composer(php-mock/php-mock-integration) < 3)
-Requires: (php-composer(php-mock/php-mock) >= 2.1 with php-composer(php-mock/php-mock) < 3)
-# remirepo:4
+Requires: (php-composer(php-mock/php-mock-integration) >= 2 with php-composer(php-mock/php-mock-integration) < 3)
+Requires: (php-composer(php-mock/php-mock) >= 2.1.1 with php-composer(php-mock/php-mock) < 3)
+# remirepo:5
%else
Requires: phpunit6
Requires: php-mock-integration2
+Requires: php-mock2 >= 2.1.1
%endif
# From phpcompatinfo report from version 2.1.0
# only Core
@@ -114,7 +116,7 @@ EOF
ret=0
: Run upstream test suite with phpunit6
-for cmd in php php70 php71 php72 php73; do
+for cmd in php php71 php72 php73; do
if which $cmd; then
$cmd %{_bindir}/phpunit6 --verbose || ret=1
fi
@@ -152,6 +154,10 @@ exit $ret
%changelog
+* Mon Apr 8 2019 Remi Collet <remi@remirepo.net> - 2.3.0-1
+- update to 2.3.0
+- raise dependency on php-mock2 2.1.1
+
* Thu Mar 7 2019 Remi Collet <remi@remirepo.net> - 2.2.0-2
- use php-mock2 2.1 single autoloader