summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-05 08:58:11 +0100
committerRemi Collet <remi@remirepo.net>2017-12-05 08:58:11 +0100
commitfb69813d5354514327c911f1a00a95561be6ec33 (patch)
tree761aba1e159a204c2c783237b90e54c3825757f5
duplicate php-mock-integration
-rw-r--r--.gitignore8
-rw-r--r--Makefile4
-rw-r--r--composer.json30
-rw-r--r--php-mock-integration2.spec112
4 files changed, 154 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..c8e1c73
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,30 @@
+{
+ "name": "php-mock/php-mock-integration",
+ "type": "library",
+ "description": "Integration package for PHP-Mock",
+ "keywords": ["mock", "stub", "test double", "function", "test", "TDD", "BDD"],
+ "homepage": "https://github.com/php-mock/php-mock-integration",
+ "license": "WTFPL",
+ "authors": [
+ {
+ "name": "Markus Malkusch",
+ "email": "markus@malkusch.de",
+ "homepage": "http://markus.malkusch.de",
+ "role": "Developer"
+ }
+ ],
+ "autoload": {
+ "psr-4": {"phpmock\\integration\\": "classes/"}
+ },
+ "require": {
+ "php": ">=5.5",
+ "php-mock/php-mock": "^1",
+ "phpunit/php-text-template": "^1"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^4|^5"
+ },
+ "archive": {
+ "exclude": ["/tests"]
+ }
+}
diff --git a/php-mock-integration2.spec b/php-mock-integration2.spec
new file mode 100644
index 0000000..845ee0d
--- /dev/null
+++ b/php-mock-integration2.spec
@@ -0,0 +1,112 @@
+# remirepo/fedora spec file for php-mock-integration
+#
+# Copyright (c) 2016-2017 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit e83fb65dd20cd3cf250d554cbd4682b96b684f4b
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner php-mock
+%global gh_project php-mock-integration
+%global with_tests 0%{!?_without_tests:1}
+
+Name: php-mock-integration
+Version: 1.0.0
+Release: 4%{?dist}
+Summary: Integration package for PHP-Mock
+
+Group: Development/Libraries
+License: WTFPL
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+
+BuildArch: noarch
+BuildRequires: php(language) >= 5.5
+%if %{with_tests}
+# from composer.json, "require-dev": {
+# "phpunit/phpunit": "^4|^5"
+BuildRequires: php-composer(php-mock/php-mock) < 2
+BuildRequires: php-composer(php-mock/php-mock) >= 1
+BuildRequires: php-composer(phpunit/php-text-template) < 2
+BuildRequires: php-composer(phpunit/php-text-template) >= 1
+BuildRequires: php-composer(phpunit/phpunit) > 4
+# For autoloader
+BuildRequires: php-composer(fedora/autoloader)
+%endif
+
+# from composer.json, "require": {
+# "php": ">=5.5",
+# "php-mock/php-mock": "^1",
+# "phpunit/php-text-template": "^1"
+Requires: php(language) >= 5.5
+Requires: php-composer(php-mock/php-mock) >= 1
+Requires: php-composer(php-mock/php-mock) < 2
+Requires: php-composer(phpunit/php-text-template) >= 1
+Requires: php-composer(phpunit/php-text-template) < 2
+# From phpcompatinfo report from version 1.0.1
+# only standard
+
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+This is a support package for PHP-Mock integration into other frameworks.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+# Same namespace than php-mock, not specific autoloader needed
+
+
+%build
+# Nothing
+
+
+%install
+mkdir -p %{buildroot}%{_datadir}/php/
+mkdir -p %{buildroot}%{_datadir}/php/phpmock
+cp -pr classes %{buildroot}%{_datadir}/php/phpmock/integration
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{_datadir}/php/Fedora/Autoloader/autoload.php';
+require_once '%{_datadir}/tests/phpmock/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('phpmock\\', '%{buildroot}%{_datadir}/php/phpmock');
+EOF
+
+ret=0
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ %{_bindir}/phpunit --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: bootstrap build with test suite disabled
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc composer.json
+%doc *.md
+%{_datadir}/php/phpmock/integration
+
+
+%changelog
+* Thu May 11 2017 Remi Collet <remi@remirepo.net> - 1.0.0-4
+- switch to fedora/autoloader
+
+* Mon Feb 22 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-2
+- Fix: license is WTFPL
+
+* Fri Feb 12 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- initial package