summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2025-02-25 09:44:51 +0100
committerRemi Collet <remi@php.net>2025-02-25 09:44:51 +0100
commit04bbb1a5d6eb033795b9051b27f9c05f5b76c86f (patch)
tree250b133f32246d6590f520044d2cc7ee78a186e5
parent15bb78b07a02c092c19192b5c078df71ff80291f (diff)
update to 2.4.0
re-license spec file to CECILL-2.1
-rw-r--r--composer.json4
-rw-r--r--php-mock-integration2.spec58
2 files changed, 31 insertions, 31 deletions
diff --git a/composer.json b/composer.json
index 8213acd..ee11b60 100644
--- a/composer.json
+++ b/composer.json
@@ -23,10 +23,10 @@
"require": {
"php": ">=5.6",
"php-mock/php-mock": "^2.5",
- "phpunit/php-text-template": "^1 || ^2 || ^3 || ^4"
+ "phpunit/php-text-template": "^1 || ^2 || ^3 || ^4 || ^5"
},
"require-dev": {
- "phpunit/phpunit": "^5.7.27 || ^6 || ^7 || ^8 || ^9 || ^10 || ^11"
+ "phpunit/phpunit": "^5.7.27 || ^6 || ^7 || ^8 || ^9 || ^10 || ^11 || ^12"
},
"archive": {
"exclude": ["/tests"]
diff --git a/php-mock-integration2.spec b/php-mock-integration2.spec
index 928e79f..b593046 100644
--- a/php-mock-integration2.spec
+++ b/php-mock-integration2.spec
@@ -1,21 +1,21 @@
# remirepo/fedora spec file for php-mock-integration2
#
-# Copyright (c) 2016-2024 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2016-2025 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
-%global gh_commit ec6a00a8129d50ed0f07907c91e3274ca4ade877
+%global gh_commit 0ea2fb4b69598eed8a300271f8e8117b143c7b2c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 2024-02-10
+%global gh_date 2025-02-25
%global gh_owner php-mock
%global gh_project php-mock-integration
%global with_tests 0%{!?_without_tests:1}
%global major 2
Name: php-mock-integration%{major}
-Version: 2.3.0
+Version: 2.4.0
Release: 1%{?dist}
Summary: Integration package for PHP-Mock
@@ -28,18 +28,15 @@ BuildArch: noarch
BuildRequires: php(language) >= 7.4
%if %{with_tests}
# from composer.json, "require-dev": {
-# "phpunit/phpunit": "^5.7.27 || ^6 || ^7 || ^8 || ^9 || ^10 || ^11"
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+# "phpunit/phpunit": "^5.7.27 || ^6 || ^7 || ^8 || ^9 || ^10 || ^11 || ^12"
BuildRequires: (php-composer(php-mock/php-mock) >= 2.5 with php-composer(php-mock/php-mock) < 3)
-# remirepo:3
-%else
-BuildRequires: php-mock2
-%endif
BuildRequires: phpunit8
BuildRequires: phpunit9
BuildRequires: phpunit10
-# TODO phpunit11 but requires php 8.2
+%if 0%{?fedora} || 0%{?rhel} >= 10
+BuildRequires: phpunit11
+BuildRequires: phpunit12
+%endif
%endif
# For autoloader
BuildRequires: php-composer(fedora/autoloader)
@@ -47,17 +44,10 @@ BuildRequires: php-composer(fedora/autoloader)
# from composer.json, "require": {
# "php": ">=5.6",
# "php-mock/php-mock": "^2.5",
-# "phpunit/php-text-template": "^1 || ^2|| ^3 || ^4"
+# "phpunit/php-text-template": "^1 || ^2|| ^3 || ^4 || ^5"
Requires: php(language) >= 5.6
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(php-mock/php-mock) >= 2.5 with php-composer(php-mock/php-mock) < 3)
-Requires: (php-composer(phpunit/php-text-template) >= 1 with php-composer(phpunit/php-text-template) < 5)
-# remirepo:4
-%else
-Requires: php-mock2
-Requires: php-phpunit-Text-Template
-%endif
+Requires: (php-composer(phpunit/php-text-template) >= 1 with php-composer(phpunit/php-text-template) < 6)
# From phpcompatinfo report from version 2.0.0
# only core and standard
@@ -98,7 +88,7 @@ EOF
ret=0
if [ -x %{_bindir}/phpunit8 ]; then
- for cmd in php php80 php81 php82;do
+ for cmd in php php80 php81 php82 php83 php84;do
if which $cmd; then
$cmd %{_bindir}/phpunit8 --verbose || ret=1
fi
@@ -106,7 +96,7 @@ if [ -x %{_bindir}/phpunit8 ]; then
fi
if [ -x %{_bindir}/phpunit9 ]; then
- for cmd in php php80 php81 php82 php83;do
+ for cmd in php php80 php81 php82 php83 php84;do
if which $cmd; then
$cmd %{_bindir}/phpunit9 --verbose || ret=1
fi
@@ -114,7 +104,7 @@ if [ -x %{_bindir}/phpunit9 ]; then
fi
if [ -x %{_bindir}/phpunit10 ]; then
- for cmd in php php81 php82php83;do
+ for cmd in php php81 php82 php83 php84;do
if which $cmd; then
$cmd %{_bindir}/phpunit10 || ret=1
fi
@@ -122,7 +112,15 @@ if [ -x %{_bindir}/phpunit10 ]; then
fi
if [ -x %{_bindir}/phpunit11 ]; then
- for cmd in php php82 php83;do
+ for cmd in php php82 php83 php84;do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit10 || ret=1
+ fi
+ done
+fi
+
+if [ -x %{_bindir}/phpunit12 ]; then
+ for cmd in php php83 php84;do
if which $cmd; then
$cmd %{_bindir}/phpunit10 || ret=1
fi
@@ -135,8 +133,6 @@ exit $ret
%files
-# remirepo:1
-%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
%doc *.md
@@ -144,6 +140,10 @@ exit $ret
%changelog
+* Tue Feb 25 2025 Remi Collet <remi@remirepo.net> - 2.4.0-1
+- update to 2.4.0
+- re-license spec file to CECILL-2.1
+
* Mon Feb 12 2024 Remi Collet <remi@remirepo.net> - 2.3.0-1
- update to 2.3.0 (no change)
- raise dependency on php-mock 2.5