summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore8
-rw-r--r--composer.json2
-rw-r--r--php-mikey179-vfsstream.spec20
3 files changed, 21 insertions, 9 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
index ecf8890..9d1f3f0 100644
--- a/composer.json
+++ b/composer.json
@@ -20,7 +20,7 @@
"php": ">=5.3.0"
},
"require-dev": {
- "phpunit/phpunit": "~4.5"
+ "phpunit/phpunit": "^4.5|^5.0"
},
"autoload": {
"psr-0": { "org\\bovigo\\vfs\\": "src/main/php" }
diff --git a/php-mikey179-vfsstream.spec b/php-mikey179-vfsstream.spec
index 9937cec..ca28cc7 100644
--- a/php-mikey179-vfsstream.spec
+++ b/php-mikey179-vfsstream.spec
@@ -1,12 +1,12 @@
# spec file for php-mikey179-vfsstream
#
-# Copyright (c) 2014-2018 Remi Collet
+# Copyright (c) 2014-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 095238a0711c974ae5b4ebf4c4534a23f3f6c99d
+%global gh_commit 2b544ac3a21bcc4dde5d90c4ae8d06f4319055fb
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner bovigo
%global gh_project vfsStream
@@ -15,8 +15,8 @@
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
Name: php-%{pk_owner}-%{pk_project}
-Version: 1.6.6
-Release: 2%{?dist}
+Version: 1.6.7
+Release: 1%{?dist}
Summary: PHP stream wrapper for a virtual file system
License: BSD
@@ -28,7 +28,7 @@ BuildRequires: php(language) >= 5.3
BuildRequires: %{_bindir}/phpab
%if %{with_tests}
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "~4.5"
+# "phpunit/phpunit": "~4.5|^5.0"
BuildRequires: php-composer(phpunit/phpunit) >= 4.5
%endif
@@ -80,12 +80,13 @@ cp -pr src/main/php/org %{buildroot}%{_datadir}/php/org
# erratic result in mock
rm src/test/php/org/bovigo/vfs/vfsStreamWrapperLargeFileTestCase.php
+mkdir vendor
+ln -s %{buildroot}%{_datadir}/php/org/bovigo/vfs/autoload.php vendor/autoload.php
+
ret=0
-for cmd in php php70 php71 php72 php73; do
+for cmd in php php71 php72 php73 php74; do
if which $cmd; then
$cmd %{_bindir}/phpunit \
- --filter '^((?!(directoriesAreNeverExecutable|directoriesAndNonExistingFilesAreNeverExecutable)).)*$' \
- --bootstrap %{buildroot}%{_datadir}/php/org/bovigo/vfs/autoload.php \
--verbose || ret=1
fi
done
@@ -105,6 +106,9 @@ exit $ret
%changelog
+* Fri Aug 2 2019 Remi Collet <remi@remirepo.net> - 1.6.7-1
+- update to 1.6.7
+
* Tue Apr 9 2019 Remi Collet <remi@remirepo.net> - 1.6.6-2
- fix vendor