summaryrefslogtreecommitdiffstats
path: root/php-mikey179-vfsstream.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-05-13 16:33:27 +0200
committerRemi Collet <fedora@famillecollet.com>2014-05-13 16:33:27 +0200
commit28515a038d49b6e452a97a12dfcdd12b69e22b70 (patch)
tree25b4d063703a1dd332b886a10195d812efb161a5 /php-mikey179-vfsstream.spec
php-mikey179-vfsstream: 1.2.0 - New package
Diffstat (limited to 'php-mikey179-vfsstream.spec')
-rw-r--r--php-mikey179-vfsstream.spec90
1 files changed, 90 insertions, 0 deletions
diff --git a/php-mikey179-vfsstream.spec b/php-mikey179-vfsstream.spec
new file mode 100644
index 0000000..443f9b2
--- /dev/null
+++ b/php-mikey179-vfsstream.spec
@@ -0,0 +1,90 @@
+# spec file for php-mikey179-vfsstream
+#
+# Copyright (c) 2012-2014 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit 063fb10633f10c5ccbcac26227e94f46d9336f90
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner mikey179
+%global gh_project vfsStream
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+
+Name: php-mikey179-vfsstream
+Version: 1.2.0
+Release: 1%{?dist}
+Summary: PHP stream wrapper for a virtual file system
+
+Group: Development/Libraries
+License: BSD
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}.tar.gz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php(language) >= 5.3
+BuildRequires: %{_bindir}/phpab
+%if %{with_tests}
+BuildRequires: %{_bindir}/phpunit
+%endif
+
+# From composer.json
+Requires: php(language) >= 5.3
+# From phpcompatifo report for 1.2.0
+Requires: php-date
+Requires: php-posix
+Requires: php-spl
+
+
+%description
+vfsStream is a PHP stream wrapper for a virtual file system that may be
+helpful in unit tests to mock the real file system.
+
+It can be used with any unit test framework, like PHPUnit or SimpleTest.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+# Nothing
+
+
+%install
+rm -rf %{buildroot}
+mkdir -p %{buildroot}%{_datadir}/php
+cp -pr src/main/php/org %{buildroot}%{_datadir}/php/org
+
+
+%if %{with_tests}
+%check
+: generate the bootstrap/autoloader
+phpab --output src/main/php/bs.php src/main/php
+
+: run test suite
+phpunit \
+ --bootstrap src/main/php/bs.php \
+ -d date.timezone=UTC
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%doc LICENSE
+%doc CHANGES composer.json
+
+%dir %{_datadir}/php/org
+%dir %{_datadir}/php/org/bovigo
+ %{_datadir}/php/org/bovigo/vfs
+
+
+%changelog
+* Tue May 13 2014 Remi Collet <remi@fedoraproject.org> - 1.2.0-1
+- initial package \ No newline at end of file