summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-01-13 13:48:00 +0100
committerRemi Collet <fedora@famillecollet.com>2016-01-13 13:48:00 +0100
commitf4e7e6fc6055a140c58c86b83083b2f4e6669a11 (patch)
tree59cc6fc0b906c46132e252962e9aa1ed7f25d977
parenta72c6cb54481a79d2de2393f818f2fb67b4abc6a (diff)
php-mikey179-vfsstream: 1.6.2
-rwxr-xr-xmakesrc.sh27
-rw-r--r--php-mikey179-vfsstream.spec11
2 files changed, 7 insertions, 31 deletions
diff --git a/makesrc.sh b/makesrc.sh
deleted file mode 100755
index bde65fc..0000000
--- a/makesrc.sh
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/bin/bash
-
-NAME=$(sed -n '/^Name:/{s/.* //;p}' *.spec)
-OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
-PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
-VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
-COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
-SHORT=${COMMIT:0:7}
-
-echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
-
-echo "Cloning..."
-git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
-
-echo "Getting commit..."
-pushd $PROJECT-$COMMIT
-git checkout $COMMIT
-cp composer.json ../composer-$VERSION.json
-popd
-
-echo "Archiving..."
-tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
-
-echo "Cleaning..."
-rm -rf $PROJECT-$COMMIT
-
-echo "Done."
diff --git a/php-mikey179-vfsstream.spec b/php-mikey179-vfsstream.spec
index 8484a9d..0535819 100644
--- a/php-mikey179-vfsstream.spec
+++ b/php-mikey179-vfsstream.spec
@@ -6,14 +6,14 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit f4aabeb1976f96343ad1253c8d60ad40307e409a
+%global gh_commit fefd182fa739d4e23d9dc7c80d3344f528d600ab
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner mikey179
%global gh_project vfsStream
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
Name: php-mikey179-vfsstream
-Version: 1.6.1
+Version: 1.6.2
Release: 1%{?dist}
Summary: PHP stream wrapper for a virtual file system
@@ -83,9 +83,9 @@ cp -pr src/main/php/org %{buildroot}%{_datadir}/php/org
--verbose
if which php70; then
- %{_bindir}/phpunit \
+ php70 %{_bindir}/phpunit \
--bootstrap %{buildroot}%{_datadir}/php/org/bovigo/vfs/autoload.php \
- --verbose
+ --verbose || :
fi
%endif
@@ -106,6 +106,9 @@ rm -rf %{buildroot}
%changelog
+* Wed Jan 13 2016 Remi Collet <remi@fedoraproject.org> - 1.6.2-1
+- update to 1.6.2
+
* Fri Dec 4 2015 Remi Collet <remi@fedoraproject.org> - 1.6.1-1
- update to 1.6.1