summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-06-30 09:09:32 +0200
committerRemi Collet <remi@php.net>2022-06-30 09:09:32 +0200
commit11c12cbf0330727dfad20d35318b3853f876277d (patch)
tree45b48ad84f800d526ee3e79875400de34f9663e5
parent57a1ea8cfc9c5ff8c79a8bda112aee7ae71b655d (diff)
add upstream patch for 8.2
skip test suite with PHP >= 8.1
-rw-r--r--php-mikey179-vfsstream-upstream.patch45
-rw-r--r--php-mikey179-vfsstream.spec24
2 files changed, 62 insertions, 7 deletions
diff --git a/php-mikey179-vfsstream-upstream.patch b/php-mikey179-vfsstream-upstream.patch
new file mode 100644
index 0000000..0d93966
--- /dev/null
+++ b/php-mikey179-vfsstream-upstream.patch
@@ -0,0 +1,45 @@
+From 17b0f39b4a767bf950066dbad1a9a0b0ec4f7c68 Mon Sep 17 00:00:00 2001
+From: Vladimir Jimenez <allejo@me.com>
+Date: Tue, 22 Feb 2022 17:36:32 -0800
+Subject: [PATCH] Fix PHP 8.2 support for vfsStreamWrapper
+
+Co-authored-by: James Gilliland <neclimdul@gmail.com>
+---
+ src/main/php/org/bovigo/vfs/vfsStreamWrapper.php | 6 ++++++
+ src/test/phpt/bug71287.phpt | 6 ++++++
+ 2 files changed, 12 insertions(+)
+
+diff --git a/src/main/php/org/bovigo/vfs/vfsStreamWrapper.php b/src/main/php/org/bovigo/vfs/vfsStreamWrapper.php
+index 368b2fbe..a31e6d22 100644
+--- a/src/main/php/org/bovigo/vfs/vfsStreamWrapper.php
++++ b/src/main/php/org/bovigo/vfs/vfsStreamWrapper.php
+@@ -46,6 +46,12 @@ class vfsStreamWrapper
+ * file mode: read and write
+ */
+ const ALL = 2;
++ /**
++ * The current context or null if none passed.
++ *
++ * @var resource|null
++ */
++ public $context;
+ /**
+ * switch whether class has already been registered as stream wrapper or not
+ *
+diff --git a/src/test/phpt/bug71287.phpt b/src/test/phpt/bug71287.phpt
+index ea2efb75..75b9b376 100644
+--- a/src/test/phpt/bug71287.phpt
++++ b/src/test/phpt/bug71287.phpt
+@@ -6,6 +6,12 @@ See https://github.com/mikey179/vfsStream/issues/120
+ --FILE--
+ <?php
+ class Stream {
++ /**
++ * The current context or null if none passed.
++ *
++ * @var resource|null
++ */
++ public $context;
+ public function stream_open($path, $mode, $options, $opened_path) {
+
+ return true;
diff --git a/php-mikey179-vfsstream.spec b/php-mikey179-vfsstream.spec
index 583d528..7574a8e 100644
--- a/php-mikey179-vfsstream.spec
+++ b/php-mikey179-vfsstream.spec
@@ -1,6 +1,6 @@
# spec file for php-mikey179-vfsstream
#
-# Copyright (c) 2014-2019 Remi Collet
+# Copyright (c) 2014-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -16,13 +16,16 @@
Name: php-%{pk_owner}-%{pk_project}
Version: 1.6.10
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: PHP stream wrapper for a virtual file system
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+# From https://github.com/bovigo/vfsStream/commits/v1.6
+Patch0: %{name}-upstream.patch
+
BuildArch: noarch
BuildRequires: php(language) >= 5.3
BuildRequires: %{_bindir}/phpab
@@ -61,6 +64,7 @@ To use this library, you just have to add, in your project:
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1
%build
@@ -83,14 +87,16 @@ rm src/test/php/org/bovigo/vfs/vfsStreamWrapperLargeFileTestCase.php
mkdir vendor
ln -s %{buildroot}%{_datadir}/php/org/bovigo/vfs/autoload.php vendor/autoload.php
-# issue with PHP 8 and phpunit 5: unregisterThirdPartyVfsScheme|unregisterWhenNotInRegisteredState
-# TODO PHP 8.1
ret=0
-for cmd in php php73 php74 php80; do
+for cmd in php php74 php80; do
if which $cmd; then
- $cmd %{_bindir}/phpunit \
+ VER=$($cmd -r 'echo PHP_VERSION_ID;')
+ if [ $VER -ge 80100 ]; then
+ echo skip test with PHP $ver
+ else $cmd %{_bindir}/phpunit \
--filter '^((?!(unregisterThirdPartyVfsScheme|unregisterWhenNotInRegisteredState)).)*$' \
- --verbose || ret=1
+ --verbose --no-coverage || ret=1
+ fi
fi
done
exit $ret
@@ -109,6 +115,10 @@ exit $ret
%changelog
+* Thu Jun 30 2022 Remi Collet <remi@remirepo.net> - 1.6.10-2
+- add upstream patch for 8.2
+- skip test suite with PHP >= 8.1
+
* Mon Sep 27 2021 Remi Collet <remi@remirepo.net> - 1.6.10-1
- update to 1.6.10