summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-08-11 09:04:52 +0200
committerRemi Collet <remi@php.net>2022-08-11 09:04:52 +0200
commit0c82f07bf85069d212ade3c31b81e8a5f5e94f32 (patch)
treef408ae60b51ecf05c3c9da2dfdd5920d8cf869ed
parent11c12cbf0330727dfad20d35318b3853f876277d (diff)
update to 1.6.11HEADmaster
-rw-r--r--php-mikey179-vfsstream-upstream.patch45
-rw-r--r--php-mikey179-vfsstream.spec13
2 files changed, 6 insertions, 52 deletions
diff --git a/php-mikey179-vfsstream-upstream.patch b/php-mikey179-vfsstream-upstream.patch
deleted file mode 100644
index 0d93966..0000000
--- a/php-mikey179-vfsstream-upstream.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From 17b0f39b4a767bf950066dbad1a9a0b0ec4f7c68 Mon Sep 17 00:00:00 2001
-From: Vladimir Jimenez <allejo@me.com>
-Date: Tue, 22 Feb 2022 17:36:32 -0800
-Subject: [PATCH] Fix PHP 8.2 support for vfsStreamWrapper
-
-Co-authored-by: James Gilliland <neclimdul@gmail.com>
----
- src/main/php/org/bovigo/vfs/vfsStreamWrapper.php | 6 ++++++
- src/test/phpt/bug71287.phpt | 6 ++++++
- 2 files changed, 12 insertions(+)
-
-diff --git a/src/main/php/org/bovigo/vfs/vfsStreamWrapper.php b/src/main/php/org/bovigo/vfs/vfsStreamWrapper.php
-index 368b2fbe..a31e6d22 100644
---- a/src/main/php/org/bovigo/vfs/vfsStreamWrapper.php
-+++ b/src/main/php/org/bovigo/vfs/vfsStreamWrapper.php
-@@ -46,6 +46,12 @@ class vfsStreamWrapper
- * file mode: read and write
- */
- const ALL = 2;
-+ /**
-+ * The current context or null if none passed.
-+ *
-+ * @var resource|null
-+ */
-+ public $context;
- /**
- * switch whether class has already been registered as stream wrapper or not
- *
-diff --git a/src/test/phpt/bug71287.phpt b/src/test/phpt/bug71287.phpt
-index ea2efb75..75b9b376 100644
---- a/src/test/phpt/bug71287.phpt
-+++ b/src/test/phpt/bug71287.phpt
-@@ -6,6 +6,12 @@ See https://github.com/mikey179/vfsStream/issues/120
- --FILE--
- <?php
- class Stream {
-+ /**
-+ * The current context or null if none passed.
-+ *
-+ * @var resource|null
-+ */
-+ public $context;
- public function stream_open($path, $mode, $options, $opened_path) {
-
- return true;
diff --git a/php-mikey179-vfsstream.spec b/php-mikey179-vfsstream.spec
index 7574a8e..abf6901 100644
--- a/php-mikey179-vfsstream.spec
+++ b/php-mikey179-vfsstream.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 250c0825537d501e327df879fb3d4cd751933b85
+%global gh_commit 17d16a85e6c26ce1f3e2fa9ceeacdc2855db1e9f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner bovigo
%global gh_project vfsStream
@@ -15,17 +15,14 @@
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
Name: php-%{pk_owner}-%{pk_project}
-Version: 1.6.10
-Release: 2%{?dist}
+Version: 1.6.11
+Release: 1%{?dist}
Summary: PHP stream wrapper for a virtual file system
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
-# From https://github.com/bovigo/vfsStream/commits/v1.6
-Patch0: %{name}-upstream.patch
-
BuildArch: noarch
BuildRequires: php(language) >= 5.3
BuildRequires: %{_bindir}/phpab
@@ -64,7 +61,6 @@ To use this library, you just have to add, in your project:
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
%build
@@ -115,6 +111,9 @@ exit $ret
%changelog
+* Thu Aug 11 2022 Remi Collet <remi@remirepo.net> - 1.6.11-1
+- update to 1.6.11
+
* Thu Jun 30 2022 Remi Collet <remi@remirepo.net> - 1.6.10-2
- add upstream patch for 8.2
- skip test suite with PHP >= 8.1