summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-03-20 09:18:44 +0100
committerRemi Collet <fedora@famillecollet.com>2017-03-20 09:18:44 +0100
commit67fef88946cf27907c9e7e8bbe90c66da4905443 (patch)
tree4a5e9577150a1b0c4d9dcdbd82b058c4aa4b8ee2
parent3fb22c74382ad2bf322f6525fc50a4c2f3649a2e (diff)
php-mikealmond-musicbrainz: backportHEADmaster
-rw-r--r--Makefile4
-rw-r--r--composer.json37
-rw-r--r--php-mikealmond-musicbrainz.spec13
3 files changed, 54 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..d49f792
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,37 @@
+{
+ "name": "mikealmond/musicbrainz",
+ "type": "library",
+ "description": "A PHP library for accessing the MusicBrainz API",
+ "keywords": ["musicbrainz", "library", "php", "api"],
+ "homepage": "https://github.com/mikealmond/musicbrainz",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Mike Almond",
+ "email": "mike.almond@gmail.com",
+ "homepage": "http://mikealmond.com",
+ "role": "Developer"
+ }
+ ],
+ "require": {
+ "php": ">=5.3.8"
+ },
+ "require-dev": {
+ "guzzle/guzzle": "~3.8.0",
+ "phpunit/phpunit": "3.7.*"
+ },
+ "suggest": {
+ "guzzle/guzzle": "Allows you to use the GuzzleHttpAdapter. You must install one of the supported adapters.",
+ "rmccue/requests": "Allows you to use the RequestsHttpAdapter. You must install one of the supported adapters."
+ },
+ "autoload": {
+ "psr-0": {
+ "MusicBrainz": "src/"
+ }
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "0.2.x-dev"
+ }
+ }
+}
diff --git a/php-mikealmond-musicbrainz.spec b/php-mikealmond-musicbrainz.spec
index f562405..d43b1d2 100644
--- a/php-mikealmond-musicbrainz.spec
+++ b/php-mikealmond-musicbrainz.spec
@@ -1,3 +1,12 @@
+# remirepo spec file for php-mikealmond-musicbrainz
+#
+# Fedora spec file for php-mikealmond-musicbrainz
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
Name: php-mikealmond-musicbrainz
Version: 0.2.2
Release: 1%{?dist}
@@ -58,6 +67,7 @@ phpunit --no-coverage --bootstrap %{buildroot}/%{_datadir}/php/MusicBrainz/autol
%files
+%{!?_licensedir:%global license %%doc}
%license LICENSE.md
%doc composer.json
%doc README.md
@@ -65,5 +75,8 @@ phpunit --no-coverage --bootstrap %{buildroot}/%{_datadir}/php/MusicBrainz/autol
%changelog
+* Thu Mar 9 2017 Remi Collet <remi@remirepo.net> - 0.2.2-1
+- backport for #remirepo
+
* Sat Mar 04 2017 Randy Barlow <bowlofeggs@fedoraproject.org> - 0.2.2-1
- Initial release.