summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-01-22 13:18:46 +0100
committerRemi Collet <remi@remirepo.net>2018-01-22 13:18:46 +0100
commit088f5899cd0ae986c98df782e3eaa43eb67a4456 (patch)
tree1699017141cf58da481d91674fcc6e9bd7ecedd5
New package
-rw-r--r--.gitignore8
-rw-r--r--Makefile4
-rw-r--r--composer.json21
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-microsoft-tolerant-php-parser.spec120
5 files changed, 181 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..9579f11
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,21 @@
+{
+ "name": "microsoft/tolerant-php-parser",
+ "description": "Tolerant PHP-to-AST parser designed for IDE usage scenarios",
+ "type": "library",
+ "require": {
+ "php": ">=7.0"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^6.4"
+ },
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Rob Lourens",
+ "email": "roblou@microsoft.com"
+ }
+ ],
+ "autoload": {
+ "psr-4": { "Microsoft\\PhpParser\\": ["src/"] }
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..87d223d
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-microsoft-tolerant-php-parser.spec b/php-microsoft-tolerant-php-parser.spec
new file mode 100644
index 0000000..9fb0841
--- /dev/null
+++ b/php-microsoft-tolerant-php-parser.spec
@@ -0,0 +1,120 @@
+# remirepo/fedora spec file for php-microsoft-tolerant-php-parser
+#
+# Copyright (c) 2018 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+# Github
+%global gh_commit 10e901a6086826376c6256954dc8903ef0ec6c9e
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner Microsoft
+%global gh_project tolerant-php-parser
+# Packagist
+%global pk_vendor microsoft
+%global pk_name %{gh_project}
+# PSR-0 namespace
+%global ns_vendor %{gh_owner}
+%global ns_project PhpParser
+
+%global with_tests 0%{!?_without_tests:1}
+
+
+Name: php-%{pk_vendor}-%{pk_name}
+Version: 0.0.8
+Release: 1%{?dist}
+Summary: Tolerant PHP-to-AST parser
+
+Group: Development/Libraries
+License: MIT
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: %{name}-%{version}-%{gh_short}.tgz
+# Create git snapshot as tests are excluded from official tarball
+Source1: makesrc.sh
+
+BuildArch: noarch
+%if %{with_tests}
+# For tests
+BuildRequires: php(language) >= 7.0
+BuildRequires: php-reflection
+BuildRequires: php-json
+BuildRequires: php-spl
+BuildRequires: php-tokenizer
+# From composer.json, "require-dev": {
+# "phpunit/phpunit": "^6.4"
+BuildRequires: phpunit6 >= 6.4
+%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+
+# From composer.json, "require": {
+# "php": ">=7.0"
+# php-parser 1.4 for autoloader
+Requires: php(language) >= 7.0
+# From phpcompatifo report for 2.1.0
+Requires: php-reflection
+Requires: php-json
+Requires: php-spl
+Requires: php-tokenizer
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+Provides: php-composer(%{pk_vendor}/%{pk_name}) = %{version}
+
+
+%description
+This is an early-stage PHP parser designed, from the beginning, for IDE usage
+scenarios. There is still a ton of work to be done, so at this point, this
+repo mostly serves as an experiment and the start of a conversation.
+
+Autoloader %{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.php
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+
+%build
+phpab --template fedora --output src/autoload.php src
+
+
+%install
+mkdir -p %{buildroot}%{_datadir}/php/%{ns_vendor}
+cp -pr src %{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}
+
+
+%check
+%if %{with_tests}
+sed -e '/memory_limit/s/"500M"/"2G"/' \
+ -e 's:src/bootstrap.php:%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.php:' \
+ -i phpunit.xml
+
+: Run the test suite
+ret=0
+for cmd in php php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit6 --testsuite invariants || ret=1
+ $cmd %{_bindir}/phpunit6 --testsuite grammar || ret=1
+ $cmd %{_bindir}/phpunit6 --testsuite api || : ignore
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE.txt
+%doc *.md
+%doc composer.json
+%dir %{_datadir}/php/%{ns_vendor}
+ %{_datadir}/php/%{ns_vendor}/%{ns_project}
+
+
+%changelog
+* Mon Jan 22 2018 Remi Collet <remi@remirepo.net> - 0.0.8-1
+- initial package