summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-01-08 13:53:10 +0100
committerRemi Collet <fedora@famillecollet.com>2016-01-08 13:53:10 +0100
commitbc203f4ffd97aff6818a1fa91d9ef78d5ca725c1 (patch)
tree4b3ece9228324afc31b758a16c10ee6b3edab92f
parentdee7e331902c9c40463dc9bbfd479ef94d2571d5 (diff)
php-mcnetic-zipstreamer: ignore test suite on 32 bits
-rw-r--r--php-mcnetic-zipstreamer.spec19
1 files changed, 14 insertions, 5 deletions
diff --git a/php-mcnetic-zipstreamer.spec b/php-mcnetic-zipstreamer.spec
index 13a9cae..de05cbf 100644
--- a/php-mcnetic-zipstreamer.spec
+++ b/php-mcnetic-zipstreamer.spec
@@ -15,7 +15,7 @@
Name: php-mcnetic-zipstreamer
Version: 1.7
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: Stream zip files without i/o overhead
Group: Development/Libraries
@@ -88,12 +88,17 @@ cp -pr src %{buildroot}%{_datadir}/php/%{namespace}
: Ensure we use our autoloader
sed -e '/^ZipStreamer.php/d' -i test/*php
-: Run test suite
-%{_bindir}/phpunit \
- --bootstrap %{buildroot}%{_datadir}/php/%{namespace}/autoload.php \
- --configuration test/phpunit.xml
+if [ $(php -r "echo PHP_INT_SIZE;") -eq 8 ]; then
+ : Run test suite
+ %{_bindir}/phpunit \
+ --bootstrap %{buildroot}%{_datadir}/php/%{namespace}/autoload.php \
+ --configuration test/phpunit.xml
+else
+ : Ignore test suite as Count64 do not support 32 bits overflow
+fi
if which php70; then
+ : Run test suite with PHP 7.0 SCL
php70 %{_bindir}/phpunit \
--bootstrap %{buildroot}%{_datadir}/php/%{namespace}/autoload.php \
--configuration test/phpunit.xml
@@ -117,6 +122,10 @@ rm -rf %{buildroot}
%changelog
+* Fri Jan 8 2016 Remi Collet <remi@fedoraproject.org> - 1.7.2
+- ensure we use our autoloader during the test suite
+- ignore test suite on 32bits build
+
* Fri Jan 8 2016 Remi Collet <remi@fedoraproject.org> - 1.7.1
- initial package
- add patch to workaround error raised by pecl_http