summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-05-27 13:44:37 +0200
committerRemi Collet <remi@remirepo.net>2019-05-27 13:44:37 +0200
commitc2a576129bbaee4a53d171ea7d0ef583921738e4 (patch)
tree62a230685bdaefece5f10e3ba2d0f85bf299077b
parentdd45817babe3d8771606c1388fb722a6c67a20bd (diff)
v2.6.0 from Fedora
-rw-r--r--composer.json6
-rw-r--r--php-masterminds-html5.spec20
2 files changed, 14 insertions, 12 deletions
diff --git a/composer.json b/composer.json
index f4f43d3..a1c059b 100644
--- a/composer.json
+++ b/composer.json
@@ -20,12 +20,14 @@
}
],
"require" : {
+ "ext-ctype": "*",
+ "ext-dom": "*",
"ext-libxml" : "*",
"php" : ">=5.3.0"
},
"require-dev": {
"satooshi/php-coveralls": "1.0.*",
- "phpunit/phpunit" : "4.*",
+ "phpunit/phpunit" : "^4.8.35",
"sami/sami": "~2.0"
},
"autoload": {
@@ -36,7 +38,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "2.2-dev"
+ "dev-master": "2.6-dev"
}
}
}
diff --git a/php-masterminds-html5.spec b/php-masterminds-html5.spec
index 89df76d..c143fc3 100644
--- a/php-masterminds-html5.spec
+++ b/php-masterminds-html5.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-masterminds-html5
#
-# Copyright (c) 2015-2017 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2015-2019 Shawn Iwinski <shawn.iwinski@gmail.com>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner Masterminds
%global github_name html5-php
-%global github_version 2.3.0
-%global github_commit 2c37c6c520b995b761674de3be8455a381679067
+%global github_version 2.6.0
+%global github_commit c961ca6a0a81dc6b55b6859b3f9ea7f402edf9ad
%global composer_vendor masterminds
%global composer_project html5
@@ -31,7 +31,6 @@ Version: %{github_version}
Release: 1%{?dist}
Summary: An HTML5 parser and serializer
-Group: Development/Libraries
License: MIT
URL: http://masterminds.github.io/html5-php
Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
@@ -42,30 +41,28 @@ BuildRequires: %{_bindir}/phpab
# Tests
%if %{with_tests}
## composer.json
-BuildRequires: %{_bindir}/phpunit
BuildRequires: php(language) >= %{php_min_ver}
-## phpcompatinfo (computed from version 2.3.0)
+BuildRequires: php-composer(phpunit/phpunit) >= 4.8.35
BuildRequires: php-ctype
BuildRequires: php-dom
+## phpcompatinfo (computed from version 2.6.0)
BuildRequires: php-iconv
BuildRequires: php-json
BuildRequires: php-mbstring
BuildRequires: php-pcre
BuildRequires: php-reflection
BuildRequires: php-spl
-BuildRequires: php-xml
%endif
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 2.3.0)
+# phpcompatinfo (computed from version 2.6.0)
Requires: php-ctype
Requires: php-dom
Requires: php-iconv
Requires: php-mbstring
Requires: php-pcre
Requires: php-spl
-Requires: php-xml
# Composer
Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
@@ -123,7 +120,7 @@ AUTOLOAD
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in "" %{?rhel:php54 php55} php56 php70 php71 php72; do
+for PHP_EXEC in "" %{?rhel:php54 php55 php56 php70} php71 php72 php73 php74; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose || RETURN_CODE=1
fi
@@ -142,6 +139,9 @@ exit $RETURN_CODE
%changelog
+* Sat May 25 2019 Shawn Iwinski <shawn.iwinski@gmail.com> - 2.6.0-1
+- Update to 2.6.0 (RHBZ #1687215)
+
* Fri Sep 08 2017 Shawn Iwinski <shawn.iwinski@gmail.com> - 2.3.0-1
- Update to 2.3.0 (RHBZ #1488271)
- Test with SCLs if available