summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-09-13 09:02:11 +0200
committerRemi Collet <remi@remirepo.net>2018-09-13 09:02:11 +0200
commitf8753f78a4ed8be4cafd141f7e37a0753201009f (patch)
tree969bf3b563d7e699ec95c84da8294ec0e877b24d
parent88b16fe57084f464e8a487e55b60be7fd1f3e1c1 (diff)
v0.5.2 from Fedora + switch to phpunit6HEADmaster
-rw-r--r--.gitignore8
-rw-r--r--composer.json59
-rw-r--r--php-maennchen-zipstream-php.spec29
3 files changed, 51 insertions, 45 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
index 861ff74..926890b 100644
--- a/composer.json
+++ b/composer.json
@@ -1,33 +1,32 @@
{
- "name": "maennchen/zipstream-php",
- "description": "ZipStream is a library for dynamically streaming dynamic zip files from PHP without writing to the disk at all on the server.",
- "keywords": ["zip", "stream"],
- "type": "library",
- "license": "MIT",
- "authors": [
- {
- "name": "Paul Duncan",
- "email": "pabs@pablotron.org"
- },
- {
- "name": "Jonatan Männchen",
- "email": "jonatan@maennchen.ch"
- },
- {
- "name": "Jesse Donat",
- "email": "donatj@gmail.com"
- }
- ],
- "require": {
- "php": ">= 5.6",
- "ext-mbstring": "*"
- },
- "require-dev": {
- "phpunit/phpunit": "4.3.*"
- },
- "autoload": {
- "psr-4": {
- "ZipStream\\": "src/"
- }
+ "name": "maennchen/zipstream-php",
+ "description": "ZipStream is a library for dynamically streaming dynamic zip files from PHP without writing to the disk at all on the server.",
+ "keywords": ["zip", "stream"],
+ "type": "library",
+ "license": "MIT",
+ "authors": [{
+ "name": "Paul Duncan",
+ "email": "pabs@pablotron.org"
+ },
+ {
+ "name": "Jonatan Männchen",
+ "email": "jonatan@maennchen.ch"
+ },
+ {
+ "name": "Jesse Donat",
+ "email": "donatj@gmail.com"
}
+ ],
+ "require": {
+ "php": ">= 7.0",
+ "ext-mbstring": "*"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^6.3"
+ },
+ "autoload": {
+ "psr-4": {
+ "ZipStream\\": "src/"
+ }
+ }
}
diff --git a/php-maennchen-zipstream-php.spec b/php-maennchen-zipstream-php.spec
index 014569c..62e8cf0 100644
--- a/php-maennchen-zipstream-php.spec
+++ b/php-maennchen-zipstream-php.spec
@@ -8,23 +8,21 @@
# Please preserve changelog entries
#
Name: php-maennchen-zipstream-php
-Version: 0.4.1
-Release: 2%{?dist}
+Version: 0.5.2
+Release: 1%{?dist}
BuildArch: noarch
License: MIT
-Group: Development/Libraries
Summary: A fast and simple streaming zip file downloader for PHP
URL: https://github.com/maennchen/ZipStream-PHP
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: php-composer(fedora/autoloader)
BuildRequires: php-fedora-autoloader-devel
BuildRequires: php-zip
-BuildRequires: phpunit
+BuildRequires: phpunit6 >= 6.3
-Requires: php(language) >= 5.6.0
+Requires: php(language) >= 7.0
Requires: php-date
Requires: php-hash
Requires: php-mbstring
@@ -52,8 +50,6 @@ zip file downloader for PHP.
%install
-rm -rf %{buildroot}
-
install -d -p -m 0755 %{buildroot}/%{_datadir}/php
install -d -p -m 0755 %{buildroot}/%{_datadir}/php/ZipStream
@@ -64,27 +60,30 @@ cp -ar src/* %{buildroot}/%{_datadir}/php/ZipStream
sed -i "s:require.*:require('%{buildroot}/%{_datadir}/php/ZipStream/autoload.php');:" test/bootstrap.php
ret=0
-for cmd in php56 php70 php71 php; do
+for cmd in php php70 php71 php72 php73; do
if which $cmd; then
- $cmd %{_bindir}/phpunit --no-coverage
+ $cmd %{_bindir}/phpunit6 --no-coverage
fi
done
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE.md
%doc composer.json
+%doc doc
%doc README.md
%{_datadir}/php/ZipStream
%changelog
+* Thu Sep 13 2018 Remi Collet <remi@remirepo.net> - 0.5.2-2
+- switch to phpunit6
+
+* Sun Sep 09 2018 Randy Barlow <bowlofeggs@fedoraproject.org> - 0.5.2-1
+- Update to 0.5.2 (#1486085).
+- https://github.com/maennchen/ZipStream-PHP/compare/v0.4.1...v0.5.2
+
* Wed Feb 22 2017 Remi Collet <remi@remirepo.net> - 0.4.1-2
- backport for remi repository