summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-01-03 11:56:10 +0100
committerRemi Collet <remi@remirepo.net>2019-01-03 11:56:10 +0100
commitab26206c8d1545466b3aae1c2edd5eb7158c916c (patch)
treebf46cc17ea4ff743e50bf5df178193f6459a6a94
new package
-rw-r--r--.gitignore8
-rw-r--r--Makefile4
-rw-r--r--composer.json38
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-league-tactician.spec118
5 files changed, 196 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..49cce09
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,38 @@
+{
+ "name": "league/tactician",
+ "description": "A small, flexible command bus. Handy for building service layers.",
+ "keywords": ["command", "command bus", "service layer"],
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Ross Tuck",
+ "homepage": "http://tactician.thephpleague.com"
+ }
+ ],
+ "require": {
+ "php": ">=5.5"
+ },
+ "require-dev": {
+ "mockery/mockery": "~0.9",
+ "phpunit/phpunit": "^4.8.35",
+ "squizlabs/php_codesniffer": "~2.3"
+ },
+ "autoload": {
+ "psr-4": {
+ "League\\Tactician\\": "src"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "League\\Tactician\\Tests\\": "tests/"
+ },
+ "files": [
+ "tests/Fixtures/Command/CommandWithoutNamespace.php"
+ ]
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.0-dev"
+ }
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..37cb6a2
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-league-tactician.spec b/php-league-tactician.spec
new file mode 100644
index 0000000..c60373b
--- /dev/null
+++ b/php-league-tactician.spec
@@ -0,0 +1,118 @@
+# remirepo/fedora spec file for php-league-tactician
+#
+# Copyright (c) 2019 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+# Github
+%global gh_commit d0339e22fd9252fb0fa53102b488d2c514483b8a
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner thephpleague
+%global gh_project tactician
+# Packagist
+%global pk_vendor league
+%global pk_name tactician
+# PSR-0 namespace
+%global ns_vendor League
+%global ns_project Tactician
+
+Name: php-%{pk_vendor}-%{pk_name}
+Version: 1.0.3
+Release: 1%{?dist}
+Summary: A small, flexible command bus
+
+License: MIT
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: %{name}-%{version}-%{gh_short}.tgz
+# Create git snapshot as tests are excluded from official tarball
+Source1: makesrc.sh
+
+BuildArch: noarch
+BuildRequires: php(language) >= 5.5
+BuildRequires: php-date
+BuildRequires: php-spl
+# From composer.json, "require-dev": {
+# "mockery/mockery": "~0.9",
+# "phpunit/phpunit": "^4.8.35",
+# "squizlabs/php_codesniffer": "~2.3"
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(mockery/mockery) >= 0.9 with php-composer(mockery/mockery) < 1)
+%else
+BuildRequires: php-deepend-Mockery >= 0.9
+%endif
+BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+
+# From composer.json, "require": {
+# "php": ">=5.5"
+Requires: php(language) >= 5.5
+# From phpcompatifo report for 1.0.3
+Requires: php-spl
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+Provides: php-composer(%{pk_vendor}/%{pk_name}) = %{version}
+
+
+%description
+A small, flexible command bus. Handy for building service layers.
+
+Documentation: http://tactician.thephpleague.com/
+
+Autoloader: %{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.php
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+: Generate a simple autoloader
+%{_bindir}/phpab -t fedora -o src/autoload.php src
+
+
+%install
+mkdir -p %{buildroot}%{_datadir}/php/%{ns_vendor}
+cp -pr src %{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}
+
+
+%check
+: Generate a simple autoloader
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+// Installed library
+require '%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.php';
+
+\Fedora\Autoloader\Autoload::addPsr4('League\\Tactician\\Tests\\', dirname(__DIR__).'/tests');
+\Fedora\Autoloader\Dependencies::required([
+ dirname(__DIR__).'/tests/Fixtures/Command/CommandWithoutNamespace.php',
+ '%{_datadir}/php/Mockery/autoload.php',
+]);
+EOF
+
+: Run upstream test suite
+ret=0
+for cmd in php php70 php72 php73; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --verbose || ret=1
+ fi
+done
+exit $ret
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%{_datadir}/php/%{ns_vendor}
+
+
+%changelog
+* Thu Jan 3 2019 Remi Collet <remi@remirepo.net> - 1.0.3-1
+- initial package, version 1.0.3
+